Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Removing extreme values manually


  • Is there a way to manually remove extreme values, if the default settings were not enough, and we did not manually set them to something reasonable?

    For example, I have a value of 6000 F for outdoor temperature, and since I'm using a meta point for averaging daily and monthly temperature, this will throw it off.

    The extreme value discard did not catch this. How can I manually remove this value?.


  • You can remove individual point values via the dataImport module. The basic process is:

    1. Export the data around the time you want to delete into CSV/Excel
    2. Import data you want to modify (check the file format as there is a column to indicate add/delete)

    1. I tried to export the data through the point details page, and I think this isn't the way, but I couldn't find another way:

    0_1481385208208_dataexport.png

    1. However, I don't have enough information to fill in all these columns that are required =(

    I can manually enter the XID, Device Name and Point Name.

    How can I get the Time, Rendered, and Annotation values?

    Also, am I supposed to type in either "add" or "delete" in the Modify column, as text?

    0_1481385231093_dataimportexample.png


  • Try the Legacy Point Details page or the Watch List. On those two pages you should get the right format and have the option to export in xls format.


  • OK that was pretty easy. Thanks fellas.

    Also, for future reference, I did just type the text value "delete" (without quotes) in the modify column, that worked.