Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Mango cannot run after installation


  • Hi there,

    I have a problem running my mango 3.7.7 after installation on raspberry pi 4. I have already install java jdk and set the JAVA_HOME environment variable. When I run the mango using command ./ma.sh start the following message appear. Please advise me how to solve this problem

    MA_HOME is /home/pi/mango3
    root@cgsprototype:/home/pi/mango3/bin# MA removing dead pid file for PID:  8487
    ma-start: MA started with Process ID:  6118
    INFO  2021-01-25T08:44:00,790 (com.serotonin.m2m2.Main.main:121) - Starting Mango 3.7.7 with Schema Version: 29 
    No protocol specified
    Exception in thread "main" java.awt.AWTError: Can't connect to X11 window server using ':10.0' as the value of the DISPLAY variable.
    	at java.desktop/sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
    	at java.desktop/sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:102)
    	at java.base/java.security.AccessController.doPrivileged(Native Method)
    	at java.desktop/sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:61)
    	at java.base/java.lang.Class.forName0(Native Method)
    	at java.base/java.lang.Class.forName(Class.java:315)
    	at java.desktop/java.awt.GraphicsEnvironment$LocalGE.createGE(GraphicsEnvironment.java:101)
    	at java.desktop/java.awt.GraphicsEnvironment$LocalGE.<clinit>(GraphicsEnvironment.java:83)
    	at java.desktop/java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:129)
    	at java.desktop/sun.awt.X11.XToolkit.<clinit>(XToolkit.java:231)
    	at java.base/java.lang.Class.forName0(Native Method)
    	at java.base/java.lang.Class.forName(Class.java:315)
    	at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:588)
    	at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:583)
    	at java.base/java.security.AccessController.doPrivileged(Native Method)
    	at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:582)
    	at java.desktop/java.awt.Desktop.isDesktopSupported(Desktop.java:328)
    	at com.serotonin.m2m2.Lifecycle.webServerInitialize(Lifecycle.java:1061)
    	at com.serotonin.m2m2.Lifecycle.initialize(Lifecycle.java:221)
    	at com.serotonin.m2m2.Main.main(Main.java:159)
    

    best regards
    Ramhuzaini


  • Hi @ramhuzaini Please provide your ma.log file.


  • Hi there. Below is the ma.log file

    INFO  2021-01-25T19:21:46,322 (com.serotonin.m2m2.Main.main:121) - Starting Mango 3.7.7 with Schema Version: 29 
    WARN  2021-01-25T19:21:48,623 (com.serotonin.m2m2.Lifecycle.webServerInitialize:1067) - BROWSE action not supported on your platform, unable to open browser at startup. 
    INFO  2021-01-25T19:21:48,679 (com.serotonin.m2m2.Lifecycle.loadLic:583) - Checking license... 
    INFO  2021-01-25T19:21:48,680 (com.serotonin.m2m2.Lifecycle.loadLic:670) - License file not found 
    INFO  2021-01-25T19:21:49,187 (com.serotonin.m2m2.db.H2Proxy.initializeImpl:64) - Initializing H2 connection manager 
    INFO  2021-01-25T19:22:00,682 (com.infiniteautomation.mango.spring.MangoRuntimeContextConfiguration.contextRefreshed:133) - Spring context 'runtimeContext' refreshed: org.springframework.context.annotation.AnnotationConfigApplicationContext@15a8c6f 
    INFO  2021-01-25T19:22:00,701 (com.infiniteautomation.mango.spring.MangoRuntimeContextConfiguration.contextStarted:147) - Spring context 'runtimeContext' started: org.springframework.context.annotation.AnnotationConfigApplicationContext@15a8c6f 
    INFO  2021-01-25T19:22:00,945 (com.serotonin.m2m2.rt.RuntimeManagerImpl.initialize:176) - Starting 0 Publishers... 
    INFO  2021-01-25T19:22:00,946 (com.serotonin.m2m2.rt.RuntimeManagerImpl.initialize:188) - 0 Publisher's started in 8ms 
    INFO  2021-01-25T19:22:07,206 (com.infiniteautomation.mango.spring.MangoRuntimeContextConfiguration.contextRefreshed:133) - Spring context 'rootWebContext' refreshed: Root WebApplicationContext 
    INFO  2021-01-25T19:22:12,432 (com.infiniteautomation.mango.spring.MangoRuntimeContextConfiguration.contextRefreshed:133) - Spring context 'jspDispatcherContext' refreshed: WebApplicationContext for namespace 'JSP_DISPATCHER-servlet' 
    INFO  2021-01-25T19:24:48,311 (com.serotonin.m2m2.Lifecycle.terminate:400) - Mango Lifecycle terminating...
    

  • @ramhuzaini
    This is very similar to the errors I have encountered running V4 Beta 5 on my Debian box.


  • Java version related?


  • @craigweb Hi Craig

    Have you find the root of the problem?

    best regards
    Ramhuzaini


  • What happens if you do...

    java -version
    

  • @dan Hi dan

    pi@raspberrypi:~ $ java -version
    openjdk version "11.0.9.1" 2020-11-04
    OpenJDK Runtime Environment (build 11.0.9.1+1-post-Raspbian-1deb10u2)
    OpenJDK Server VM (build 11.0.9.1+1-post-Raspbian-1deb10u2, mixed mode)
    pi@raspberrypi:~ $ javac -version
    javac 11.0.9.1


  • @ramhuzaini
    can you try using a different GUI?


  • @cwangv Hi

    What do you mean by different GUI?


  • @ramhuzaini
    I can see you are using X11 as your GUI environment (windows like). Can you try Gnome or something else?


  • It should be all running in command line.

    Maybe Java is looking for a default browser, try installing Links or Lynx
    Or if you have XWindows installed, check it has a default web browser?


  • If it is looking for a default browser, the setting for opening a browser on boot complete can be disabled via the env.properties file. If dan has found this to be an issue, try disabling the setting (Set to false) and see how mango behaves.
    Also try ensuring all mango directories are run and owned by mango.

    Fox


  • Hi everyone,

    I have solved the problem. The problem is that I cannot run Mango through remote desktop connection. It has to be run directly from the pi. Anyway that everyone for your advice

    best regards
    Ramhuzaini


  • Would have helped if you had mentioned the remote desktop part a bit sooner...
    If you want remote access, use a VPN. It is secure and easy to set up.

    Fox


  • @mattfox
    Ok thanks for that information. Will do that.

    best regards
    Ramhuzaini