Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • Hello,

    Whether I use the step or bar option, I can not get any bargraphs filled.

    What is missing from my settings?

    Best regards

    0_1565077097796_bargraph.png
    0_1565077115469_bargraph_config.png
    0_1565077131379_bargraph.png


  • This post is deleted!

  • Hi @JF89

    Can you show what is happening when you stake all the settings off the watchlist? Your first picture and the 3rd picture is the same.
    The watchlist will use the default point chart setting which is set to bar. What is the logging interval on your kwH point, if you use delta it will show the delta between log entries if there is no change then the bar will be 0.
    Id like to see what happens I you change the rollup interval to 1 hour by changing it on your date bar.
    0_1565087683379_Screen Shot 2019-08-06 at 12.33.50.png


  • Hi JF89,

    I was not able to replicate, though I did notice I had to refresh the watch list page after changing the chart settings on the data point to have them take effect. Could that be related? I see you're on 3.6, but is it the latest release?


  • @phildunlap said in Bargraphs not filled:

    I was not able to replicate, though I did notice I had to refresh the watch list page after changing the chart settings on the data point to have them take effect. Could that be related? I see you're on 3.6, but is it the latest release?

    Hello Phil and BG,

    I tried to record one hour, but I do not have a bar graph anymore.
    I tried to change the step option to bar without success.
    I tried to have a display on one hour, but without success.
    (I specify that this is a counter on a numeric value, the rollup is set to Delta)
    at 11 pm, I put the recording on one minute, and I finally got a bar, but still without being filled.
    I don't know if the software is up to date ?
    I havent got the advance scheduler on Mango .
    Do i have to dowload that module especially ? (it should have been with all the package 3.6 ? No ?
    Best regards
    0_1565125972962_version mango.png
    0_1565126126511_version mango 2.png
    0_1565126145647_last 3 hours.png

    0_1565126159263_a 23 heures.png
    0_1565126178586_last hour.png


  • I havent got the advance scheduler on Mango .

    Do i have to dowload that module especially ? (it should have been with all the package 3.6 ? No ?

    Yes, I believe it should have been in the bundle download on the store if that's what you mean, yes. You can install it from the modules page by checking for updates, it would appear in the "available for installation section". It's not clear if you're fully up to date from the images you posted.

    It does appear to be missing from the bundle currently, so I'll look into that and thanks for bringing it to our attention.

    I tried to change the step option to bar without success.

    Assuming you are fully up to date, does this happen every time? As I said, I was not able to replicate. Can you give more detailed instructions on how to cause the issue?


  • Can you show us a bar graph and its settings that are not working? I don't see what is wrong with the step chart. It is showing the delta of the point?


  • @phildunlap

    Hello Phil,

    After installing the latest version 3.6.4 and advanced sheduler packages, I can not get the program ( in Event Handlers) I just programmed into the UI.
    Screen copy attached
    Best regards

    0_1565185837327_advanced_schedule2.png

    i followed the tutorial, but Nothing in Event Handlers !

    0_1565185936338_advanced_schedule.png


  • @craigweb
    Hi Craig,

    Here is what I expected to have, as chart for the meter (filled in orange)
    0_1565188885262_watchlist_meter_temp2.jpg

    And here is what I actually have for the counter, regardless of the setting chosen step or bar:
    the interior of the graph bar is not filled, as I hoped. (It's just a question of aesthetics, and in my opinion it's prettier when it's filled)
    0_1565188937861_watchlist_meter_temp2.png

    In yellow, it is a temperature represented in bar form, and logging point every 1 minute
    The counter in orange, has a setting on the rollup with Delta, and logging point every 10minutes.

    Best regards


  • Ok thanks for that, can you go the data point details page of COMTAGE CLiM and show us what the chart is doing there. That is definitely not a bar chart, a bar chart has the time stamp in the middle of the bar look below. That is a step chart.
    We just need to figure out why it is changing to a step chart
    0_1565189609933_Screen Shot 2019-08-07 at 16.52.38.png


  • Hello Craig,

    It's very strange, because in the EDIT menu of the variable COUNT CLIM, I have the graph that is displayed as a bar graph filled, as you will see on the following screen recopies.
    Why then, the bar chart does not appear as a bar in the Watch list? (but only a vertical line), or bar not filled.

    Best regards

    0_1565209929533_watchlist comptage clim.png

    0_1565209943758_watchlist comptage clim2.png
    0_1565209958233_watchlist comptage clim3.png
    0_1565210074106_watchlist comptage clim4.png


  • It looks like it's a static watchlist. You can save a static watchlist with a series selected and charted with a chart type other than its default. if you check the Configure all points/series checkbox below the chart, do any of the series have a chart type selected in that setting?

    Even if it were saved that way, though, removing the point from the chart and adding it back was sufficient for me to see it change back to its configured chart type rather than it's saved type.


  • Hello Phil,
    you were right, ticking the configure all points option, the counter is declared in step instead of bar.

    When in the Watch list, I only have the counter, the graph bar is correctly displayed as a bar.
    But when in this Watch list, I add a temperature, the graph bar of the meter is transformed into a vertical line
    if I delete the counter and reactivate it, I still have the same problem.

    Is it really possible to mix the two types of bar and line curves in the same graph?

    Thanks for your help

    Best regards
    0_1565245134652_watch_list_bar.png
    0_1565245166927_watch_list_cpt_temp.png
    0_1565245184254_watch_list_cpt_temp2.png


  • Hi @JF89

    If you want a chart like this:
    0_1565247206488_Screen Shot 2019-08-08 at 08.52.08.png
    You will need to add a rollup to your point that is on the line chart. :
    0_1565247352813_Screen Shot 2019-08-08 at 08.55.35.png
    Also make sure that your databar is set to auto :
    0_1565247360767_Screen Shot 2019-08-08 at 08.54.48.png


  • Hello Craig,

    Thank you very much.
    It works .
    Best regards
    0_1565277332048_watch list meter and temp.png