Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Cannot create a BACnet I/P data source


  • I want to create a BACnet I/P data source and I get the following error, plus a continuous loading icon at the bottom.

    RequestError: Unable to load /data_source_properties.shtm?typeId=BACnetIP status: 0

    0_1480973826845_nobacnet.png


  • Hi Mihai,

    Can you check your logs for any exceptions?

    Can you also try deleting the contents of your Mango/work/jsp directory and reloading the page?


  • Deleting the contents of mango/work/jsp seems to have resolved the issue.

    On the other hand, after checking ma.og, I found the following errors:

    ERROR 2016-12-05 04:08:54,415 (com.serotonin.m2m2.rt.maint.UpgradeCheck.run:54) - java.lang.Exception: Module abpccc 1.3.0 is not compatible with core 2.8.2
    ERROR 2016-12-05 08:08:54,455 (com.serotonin.m2m2.rt.maint.UpgradeCheck.run:54) - java.lang.Exception: Module abpccc 1.3.0 is not compatible with core 2.8.2
    ERROR 2016-12-05 12:08:54,366 (com.serotonin.m2m2.rt.maint.UpgradeCheck.run:54) - java.lang.Exception: Module abpccc 1.3.0 is not compatible with core 2.8.2
    ERROR 2016-12-05 16:08:54,400 (com.serotonin.m2m2.rt.maint.UpgradeCheck.run:54) - java.lang.Exception: Module abpccc 1.3.0 is not compatible with core 2.8.2

    Then I got the urge to try and check for upgrades, but I get the same error in a pop up:

    0_1480977805892_versioningproblem.png


  • Check out this post: http://infiniteautomation.com/forum/topic/2570/cannot-be-upgraded-due-to-versioning-problem/2

    If you don't need the Allen Bradley modules just uninstall them first.


  • OK all is well.

    Thanks you two.


  • By the way, we got approval from the vendor to update and distribute these module for 2.8.x so they are now available in the store and people updating to 2.8 should be fine.