Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Serial data source causing crash


  • Hi all,
    I just deleted a data source (modbus IP) that I was using for testing purposes. Mango then crashed/shut down and now wont load. It gets to 40/50% and gives and error Unable to load /mango/status/ status:0

    The cmd window closes and there are no errors in ma.log.
    No other changes were made to mango or java.

    Mango version is 3.7.7.
    Java Version is AdoptOpenJDK 11.0.6.10

    EDIT: This appears to be a serial/com port issue. I have set up some modbus serial data points but when I enable the data source Mango crashes. It wont restart until I delete the database. No errors in ma.log, it just crashes when starting data sources.

    EDIT 2: I have tried a USB to RS485 converter in case it was a com port issue but it is also crashing Mango when I enable the data source. I have confirmed the converter is working using ModbusPoll on the same PC and slave device.

    Any Ideas? Thanks

    Rob


  • Hi Rob

    Can you have a look if there is a pid_error file in your mango directory after the crash.


  • Hi Craig, There is indeed! WIll I post it?


  • Hi Rob can you email it to us.


  • Done. Thanks Craig.


  • I'm getting this as well.

    I restored from a windows crash and using the recommended AdoptOpenJDK JDK. I was using the old JDK from Oracle prior. I now get this error and I know the port works fine as I can communicate using a modbus master tool.


  • @chrapchp Have you tried going back to Oracle JDK? I ended up using a Modbus gateway.


  • @robmalone Mango did not even what to start up with JDK 1.14. I did recover the old jdk I was using on the crashed system and will revert to that.

    thx