Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Values not showing up in v3 pages but will in v2


  • I'm having a strange difficulty in getting values on my pages. System is running v3.5.6 running on a Windows 2012 Server R2. What's odd is that I can see them when looking at v2.

    0_1549969662374_6835bcfb-a830-496b-af9d-57290d6fc423-image.png
    The below returns nothing, yet attached the image of the same point in v2.

    <div class="ma-designer-root" id="9c7ca34c-0469-4d1e-8720-25a00cf9c679" style="width: 1366px; height: 768px; position: relative;">
        <ma-point-value 
            id="c261279f-c001-4262-81ff-dc498c57080c" 
            enable-popup="hide" 
            style="position: absolute; left: 114px; top: 71px; width: 237px; height: 59px;" 
            point-xid="DP_621428cb-48d9-4809-ae22-e09ee28ad7f1">
        </ma-point-value>
    </div>
    

  • Hi Gordoe

    Could you please right click on your V3 page and click inspect, navigate to the console tab and let us know if there are any errors in your browsers console.


  • Yup, there are errors.

    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78 Markup '<md-button flex></md-button>' may not work as expected in IE Browsers. Consult 'https://github.com/philipwalton/flexbugs#9-some-html-elements-cant-be-flex-containers' for details.
    (anonymous) @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78 Markup '<md-button flex></md-button>' may not work as expected in IE Browsers. Consult 'https://github.com/philipwalton/flexbugs#9-some-html-elements-cant-be-flex-containers' for details.
    (anonymous) @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78
    /rest/v2/data-points/DP_Site99_CB2-breakerStatus:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78 Possibly unhandled rejection: {"data":{"cause":null,"mangoStatusName":null,"mangoStatusCode":-1,"localizedMessage":"Not found"},"status":404,"config":{"method":"GET","transformRequest":[null],"transformResponse":[null],"jsonpCallbackParam":"callback","timeout":{},"url":"/rest/v2/data-points/DP_Site99_CB2-breakerStatus","headers":{"Accept":"application/json, text/plain, */*","X-Requested-With":"XMLHttpRequest","X-XSRF-TOKEN":"026c6a9d-22d7-4ded-b59d-1ab329306058"},"cached":false},"statusText":"Not Found","xhrStatus":"complete","mangoStatusText":"Not found","resource":{}}
    (anonymous) @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78
    

  • Please do the same on your dat apoint details page with an internal mango point


  • @craigweb When I look at the pages on the server they work, yet it's not working from my desktop. Might be firewall related/vpn related. Here is the error log from my desktop.

    The server is running with a dual nic. Think that might have an impact?

    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78 Markup '<md-button flex></md-button>' may not work as expected in IE Browsers. Consult 'https://github.com/philipwalton/flexbugs#9-some-html-elements-cant-be-flex-containers' for details.
    (anonymous) @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72 WebSocket connection to 'ws://172.30.0.5/rest/v1/websocket/json-data' failed: Error during WebSocket handshake: net::ERR_CONNECTION_RESET
    a.openSocket @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72 WebSocket connection to 'ws://172.30.0.5/rest/v1/websocket/events' failed: Error during WebSocket handshake: net::ERR_CONNECTION_RESET
    openSocket @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78 Markup '<md-button flex></md-button>' may not work as expected in IE Browsers. Consult 'https://github.com/philipwalton/flexbugs#9-some-html-elements-cant-be-flex-containers' for details.
    (anonymous) @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:78
    mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72 WebSocket connection to 'ws://172.30.0.5/rest/v1/websocket/point-value' failed: Error during WebSocket handshake: net::ERR_CONNECTION_RESET
    a.openSocket @ mangoUi~ngMango~ngMangoServices.js?v=0f03d20f7b30b4a597f9:72
    

  • Issue was firewall related.


  • @gordoe said in Values not showing up in v3 pages but will in v2:

    /rest/v2/data-points/DP_Site99_CB2-breakerStatus:1 Failed to load resource: the server responded with a status of 404 (Not Found)

    This indicates that the data point with XID DP_Site99_CB2-breakerStatus doesn't exist but that doesn't seem to be the data point you are looking at.

    @gordoe said in Values not showing up in v3 pages but will in v2:

    The server is running with a dual nic. Think that might have an impact?

    Not unless your routing is setup incorrectly.

    @gordoe said in Values not showing up in v3 pages but will in v2:

    WebSocket connection to 'ws://172.30.0.5/rest/v1/websocket/json-data' failed: Error during WebSocket handshake: net::ERR_CONNECTION_RESET

    WebSocket issues normally indicate that there is a transparent proxy between the client and the server. We always recommend to use HTTPS for security and reliability of WebSocket connections.

    The old UI pages use a long polling technique not WebSockets so this does not affect them.