Save
Saving
  • usi usi

    This is exactly the reason why I cannot understand the cause of the error. There is also no problem when I use the Modbus tool or a secondary modscan tool. Values ​​come regularly, errors come regularly, although there is no communication problem. Here I share the results I got when scanning with the device's modbus tool and secondary modscan scanner. And of course the device receives queries from a single source.
    In addition, the slave monitor points in the loop indicate that the communication was successful.

    2021-03-31_07h19_48.jpg

    posted in User help read more
  • usi usi

    @cwangv For example, I am sharing the average graph of a current point with an error in 1 week and 2 hour periods.
    i2.jpg

    posted in User help read more
  • usi usi

    @cwangv
    Yes, when I query it with the modbus tool, I can get the values ​​properly. Since my master device is in a remote location, I couldn't change the baudrate rate, I'll try this. Other than that, I can't think of any other suggestions. Now my data points are still reading correctly, but I keep getting errors at the same time.

    posted in User help read more
  • usi usi

    Hello everyone, have a nice week, first of all
    I must say that I tried extending the timeout time and selecting the Contiguous batches only option as a solution when similar problems were encountered before.

    I am sharing the current alarm list photo of my 2 modbus datasource sources. The timeout times at the interfaces of my slave devices belonging to the relevant modbus data sources are 3000ms and 10000ms, and 5000ms and 5000ms on the mango.os side. My modbus data sources produce a lot of errors, although the points return correct values. Could this be due to the baudrate settings on the field related to the problem? Or does anyone have a suggestion on the mango side that I can interfere with?

    bir.jpg iki.jpg
    uc.png

    fault text

    posted in User help read more
  • usi usi

    Hello to everyone,

    I prepared a language translation file for Mango 4.0. I adapted the file here to Turkish.

    github

    Mango does not see my translation file, when I examine the module part, I see such a screen. Do I need to change the file location?

    C: \ Program Files \ Ma_home \ web \ modules \ deviceConfig \ classes \ i18n_de.properties

    ds.jpg

    posted in How-To read more
  • usi usi

    I checked the multipliers of the data points on your recommendation. IP change occurred due to revision in servers. For this reason, it seems like a problem arising from our querying and processing data other than the data point we target. For now the problem seems to be gone, I will inform you again when the ports are opened,
    thanks Terry.

    posted in User help read more
  • usi usi

    Hi Matt,

    We encountered this problem in version 3.7.7.
    Since the file characters exceed the 32767 limit, I could not add it to the code text. Can you download the ma.log file from the link below?
    lma_log

    posted in User help read more
  • usi usi

    Hi,

    We get such an error from the data source we were able to access earlier. Although communication states are successful, we cannot read data. What could be the cause of this problem?

    48b0abb1-3824-4aa6-8948-c80e5efd5081-image.png
    2fcfd728-6576-4881-a2e8-23619b74f860-image.png

    posted in User help read more