Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

[Solved] Timer already canceled error


  • Hello everyone,

    I'm having difficulties with meta points using a CRON patern.
    As soon as I disable them, if I enable them again the message "Timer already canceled" pops up and all meta points with CRON stop being updated.

    I'm running Mango under Ubuntu 10.04LT with Tomcat6 downloaded from Mango website.

    Have some of you run into that issue?

    Thanks for your help


  • I can't recreate. Is there an error message with stack trace in the Tomcat console? Also, what version of Mango are you using?


  • Thank you very much for your answer mlohbihler,

    I have put a log extract just when the error occurs (2010-11-14 21:18:37,306) in the attached file.
    In the beginning of the Catalina log file I can see the Tomcat version:
    INFO: Starting Servlet Engine: Apache Tomcat/6.0.20

    I can see also an info at beginning of log file, could it be linked to the problem?
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-openjdk/jre/lib/i386/client:/usr/lib/jvm/java-6-openjdk/jre/lib/i386:/usr/lib/jvm/java-6-openjdk/jre/../lib/i386:/usr/java/packages/lib/i386:/usr/lib/jni:/lib:/usr/lib

    I have read there was a bug in Tomcat 6.0.24 causing the same error message but I'm not sure it is linked:
    https://issues.apache.org/bugzilla/show_bug.cgi?id=48971

    Thank you for your help,

    Alex

    Attachment: download link


  • If nothing helps:

    First Install sun-java6-jdk
    Second deinstall any openjdk and gcj stuff - you have now a clean java system. I had some difficulties with openjdk6 after installing suns jdk and removing openjdk its working.

    Arne


  • Is this still an issue?


  • Hello mlohbihler and apl,

    I have installed Sun Java, removed OpenJava and Mango has been running without issue since then.
    I believe the issue is definitively solved.

    Thanks a lot!! :D

    Alex