Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • I am trying to force reading multiple SNMP type DataPoints via button in "Data Point Details" window and also via script using RuntimeManager.refreshDataPoint (XID) function.

    0_1600335331383_snmp3.PNG
    0_1600334587367_snmp1.PNG

    But in both ways I get a binding error with the equipment and the acquisition of the OID information does not work. I have tried it with SNMP peripherals of different types and it happens to me with all.

    0_1600335460796_snmp2.PNG

    Is it not possible to do the immediate acquisition of the datapoint in this way? Do I need to additionally configure anything to use this method?


  • Any idea????

    I have been able to see through wireshark captures that the difference between a polling and forcing the reading of the SNMP datapoint is that through the forced reading, Mango does not send the requested oid in the UDP datagram. It's a bug?

    0_1600755307801_snmp request 1.PNG

    0_1600755311040_snmp request 2.PNG


  • HI @jcaballeroa

    The force read command does a batch poll then only updates that point. Is the point perhaps a Trap point only ?


  • @craigweb said in Force read SNMP:

    The force read command does a batch poll then only updates that point. Is the point perhaps a Trap point only ?

    Hi @CraigWeb, thanks for your answer.

    I have only two options to configure this DataPoint: "Poll and trap" or "Trap only".

    My configuration is "Poll and trap" and the force read command not work properly or i am made something bad.

    0_1600860548185_asgd.png


  • You cannot force read Trap only.

    There is a . in the first char of the OID. Are you sure that is correct?


  • @craigweb

    Yes, I'm pretty sure it's correct.

    In fact, the usual polling of the datasource does work correctly. If I configure it for example every 10 minutes, I get the value without problem. The problem is if I need to force the value at a given moment before those 10 minutes, I have tried to force the reading and that is when it gives the error. The difference between both requests is the capture of the wireshark that I put in a previous post, by means of polling the datasource the oid is included in the datagram, but if I make a forced request the oid does not appear in the datagram.


  • ok, give me a little time I have an snmp modem I can test with, I will see if I can replicate the error.


  • Of course, the time you need. Thank you very much for the feedback.


  • @CraigWeb Do you have any choice?


  • @jcaballeroa I was able to replicate it, there is a bug. Once the bug is fixed it will be announced in the forum.