Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Meta Data Point does not work with two context points

  • I will start with a simple explanation and add any further detail if needed. I have a Meta Data Source with a point that calculates a very simple difference between two context data points. The script validates during the set up, but the point does not calculate when saved. It works fine if I only use one data point context and a hard number but not two context data points. It does not matter from what other data sources I use, it always fails with two context points. I can have both checked for context, or just one, but still no go. The naming is fine or it wouldn't validate. So I am at a loss with this very simple point.

    Any ideas?

    Any further info needed?

    Thanks in advance.
    PS - I also searched this forum for anything, and did not find much.

    Version is 3.7.x with all updates completed a few days ago.

  • If you can share your script and a JSON export of your Data Point that would be the first step to find out what other questions there might be.

  • Here is the json.

    "name":"Delta Upstairs Attic",
    "script":"var tempvar1 = p59.value;\nvar tempvar2 = p58.value;\nreturn tempvar1 - tempvar2;",
    "readPermission":"superadmin, user",
    "setPermission":"superadmin, user",

  • Joel,

    I am embarrassed, but you helped me find it with the json. I did not realize I had limits set on the discard values. I new it was something simple. Problem solved. I must have copied this point.