Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

A Bit Stuck on Writing Multiple MODBUS Registers


  • Seems like perfect troubleshooting conditions :)
    ye so basically no response from the command. Only thing I can suggest is checking if the actual number is causing the "no response" by sending a different digit. is the modbus request going over the network or do you have a local mango instance there ?


  • Yeh the Mango instance is a few hundred ms away. It seems to work fine reading in voltages and RPM's and the like. Just been playing up a little today probably due to the weather.
    Even when it was working fine the write function still didn't seem to be the correct syntax.


  • If I was troubleshooting I would create data points instead of using the modbus tool. It looks like you are using quite an old version of mango and I have had issues with the modbus tool in older versions. I think it would be worth cancelling that out of the troubleshooting.


  • OK, thanks Craig. I have a data point I made earlier which I will go back to and see what it does.
    Thanks


  • So I emailed DSE from their website contact form for shits and giggles, not really expecting to hear back... A nice fella from the UK emailed back almost immediately with all the official docs on the thing. I thought that was awesome.. Anyway, here's a more explanatory version of what I had found originally...

    0_1595416069873_69719d29-dae3-4c8b-adb2-d135b9f6d889-image.png
    0_1595416123361_de62073f-3f72-412c-a056-53c21c664afa-image.png

    So looking at that, I should be sending 35702 to 4104 and 29833 to 4105
    :)
    I'll give that a go..


  • I may be wrong here but I am pretty sure that the only way that mango will write them in the same command is if you use 1 x 4-byte data point.


  • ok sweet as, thanks for that I'll give it a go


  • You should capture the command with Wireshark and see if it matches what you are expecting.


  • I tried a little bit of script magic to see if it would do it at the same time, but I think still not quick enough..
    0_1595418651817_c2b6021c-e189-4a1e-8117-28a42226f4b1-image.png

    0_1595418680470_2482c105-ebe7-4717-bdf9-643997d448b8-image.png

    I guess I need to combine the two 16 bit values into one 32 bit value, then write that to the single register, which should extend to the second yeh?


  • exactly