Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Overriding Module's i18n Files


  • I'm using Mango 3.7.7 and I'm wondering if there is a way to override a module's i18n.properties files? For example the file:

    {MANGO}/web/modules/mangoUI/classes/i18n.properties
    

    I've tried placing the modified file in several different locations within the overrides folder, and also just concatenating it to my existing core i18n.properties override file.

    So far the only way I've gotten it to work is by replacing the actual file within the module, which will be overwritten during any updates.

    These are the paths I have tried:
    {MANGO}/overrides/web/modules/mangoUI/classes/
    {MANGO}/overrides/web/modules/mangoUI/properties/
    {MANGO}/overrides/properties/


  • HI @wfoster-syscor

    {MANGO}/overrides/web/modules/mangoUI/classes/i18n.properties should work, can you confirm that you are restarting mango for it to take affect?


  • I can confirm that I am restarting Mango after copying the file. I tried using the {MANGO}/overrides/web/modules/mangoUI/classes/i18n.properties again to check and still no luck. I copied the original back to the main location and the modified file to that path and after restarting all of the default strings are back.

    I have several files within the {MANGO}/overrides/web/modules/mangoUI/web directory which are loaded and working fine, but it seems that the module's classes directory isn't using the overrides.


  • ok thanks for confirming that, seems like there is something I'm not aware of. Hopefully, @Jared-Wiltshire can advise.


  • @wfoster-syscor Just put your custom translations in overrides/classes/i18n_en.properties (for English). This way you can just put in the strings you want to override.


  • Great, thank you. Changing the name to include the _en and putting it into the overrides/classes directory worked perfectly.