Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Raspberry PI 3 B+ Mango and java oracle installation

  • Hello,

    I followed your tutorial to install mango on raspberry PI.

    I’m blocked whith the command prompt :

    sudo update-alternatives --install java /usr/bin/java /usr/local/java/jdk1.8.0_221/bin/java

    as you can see with the following screenshot :


    i don’t know linux , and I found on the web a syntax to declare the path for
    :/usr/local/java/jdk1.8.0_221/bin but i don’t know if it’s the good syntax.
    Here it’s what I wrote on the /etc/environment file :


    Is-it correct for the path ?

    If yes , have you got any idea of my problem ?

    I can obtain JDK as you can see in the following screenshot, but not the java version :

    0_1568297062870_reponse java version.jpg

    Best regards

  • Hi JF89,

    What precisely is your question? How to run that update alternatives command?

    Setting JAVA_HOME in the /etc/environment should be sufficient to have Mango find the java executable, and is in fact preferred in the startup scripts to resolving java from the PATH.

    I would strongly advise against assigning to the PATH variable in /etc/environment as you seem to be doing.

    Have you tried to start Mango?

  • Hello Phil,

    i have many difficulties how to use linux, and i followed your tutorial step by step.
    But I encountered the problem with the path.
    In your tutorial you said :

    Add the following to the file
    If you have path settings add at the end of PATH following :/usr/local/java/jdk1.8.0_131/bin”
    save /etc/environment (ctrl+x)

    But the syntax is not given by the tutorial.

    So that’s why I’m lookink for help.

    With your previous comment I know now that the path is not good . But i still don’t know how to write that path in etc/environment.

    I tried to start mango with sudo ./ start command in the bin directory of mango , but mango doesn’t work

    is_it because java JRE is not answering ?
    because when I check java -version , I have no answer.

    When you install JDK, does it install in the same time JRE ?

    best regards

  • here is the screnshot of the check starting mango


  • You can see in Mango/bin/ that it would preferentially use JAVA_HOME.

    From your error image, although i do not speak the language, I wonder if you have a /usr/bin/java and if it is executable. But, you should be able to launch Mango using only JAVA_HOME. I would add an echo into to see what JAVA_HOME is when it is deciding how to find Java.

  • Hello Phil ,

    The file /usr/bin/java is present , but when i try to execute it nothings happens. is containing already echo but i don’t know how to add one.
    As I said I don’t know how to use linux, just very few commands.

    The situation has been improved but not at all.

    I can start Mango , but it’s blocked with 5% starting


    I was unable to have the good echo when usin oracle jre 1.8.0_221

    So with the command sudo update-alternatives --config java , I choose an another version than oracle 1.8.0_221 :


    ![0_1568378879190_20190913_143216.jpg](Uploading 100%)

    Now I can have a good echo for java -version

    I updated the etc/environment file with the following
    JAVA_HOME= »/usr/lib/jvm/java-8-openjdk-armhf/jre/bin/java»

    Of course there’s a problem to launch the display , because I use VNC viewer but I can see the Mango software starting when typing localhost :8080 in the webbrowser bar.

    But why Mango is blocked at 5% when starting ?

    Is-it because it’s not a oracle version of java ?

    Thanks for your help

    Best regards



  • Here is the screenshot of java versions available0_1568379059946_20190913_143216.jpg

  • The screenshot of launch output's stacktrace could be prevented by setting the entry web.openBrowserOnStartup=false

    Those screenshots prove Mango has found Java and that is not the problem, as Mango is using the JAVA_HOME variable to locate Java.

  • Hello Phil,

    It works now , connecting directly to the raspberry PI .

    But the display between custom pages or settings pages takes about 3 to 5 seconds delay, and sometimes more.

    Is-it due to the ram (only 1 gb with raspian ?)

    With a computer core I5 8th generation 3,5 Ghz , 8 GB ram , W10 , the display between pages is less than a second.

    Is it as fast for the MangoHTS ( 8GB RAM max ). (display between pages less than a second ?)
    Best regards

  • The amount of memory, other things you're doing with your browser, all could affect it. I don't know specifically where the bottlenecks are in your circumstance, nor have I collected that benchmark.