Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Modbus Data Source Modbus Read Data / Write Data/ Point Locator not working right.


  • Okay: (2) things here:

    Item 1) I Just updated to Mango 3.6.0, and the Modbus tools (Modbus Slave Scan, Modbus Read Data, Write Data, and Point Locator Test) no longer seem to work. You click "read data" and it just sits there on the legacy page, with no error showing up. I did replace the libjssc-java as I discussed in another thread, as otherwise on ARM the property pages won't load at all.

    On the snazzy new page, you click "read data" and you get the following error:

    "Error reading registers - Validation failed, property "configuration.commPortId" -- Required Value"

    This is on a running data source (ie, the system is polling, and data seems to be coming in over the configured data source (in my case, /dev/ttyUSB0)

    Screen shot below.

    Item #2) It appears as if the "flashing save" icon on the legacy Modbus configuration page page never stops flashing after being clicked. I've been playing with this, and set it flashing after changing comm ports, and now it's still flashing, minutes later. Am I missing something with this? I just tried this on the New Point Data Source Configuration Page, and it appears to save properly. Is saving with the Legacy Data Source editor now non-functional for Modbus serial points?

    0_1561443461377_Comm_PortID-RequiredValue.PNG


  • The flashing save problem on the legacy page has been around for a while. I noted it is normally caused by having multiple legacy tabs open. There was no regression of functionality in the legacy pages.

    Have you tried using the Modbus tool on the working Modbus data source? This will tell us if it is a configuration problem. When you do this please close the legacy tabs.

    Edit: Sorry I read again and you did confirm this. Please try this with the legacy tabs closed.


  • The legacy UI definitely has issues with multiple tabs/windows. I'll be looking into the issue with the Modbus tools today. Thanks for letting us know.


  • Thanks for the quick updates: @CraigWeb @Jared-Wiltshire

    This fixed the Modbus tools, and I just tested it, so we're good to go. Thanks for that. These tools are Super Useful, as even thought Modbus has been around for longer than I've been alive, people who implement it still can't agree if it's 0-indexed or 1-indexed, or what the actual difference is between holding and input registers are.

    Also, I verified the flashing save Icon issue with multiple tabs... I think I noticed this before, but in my exhausted stupor the previous night I was sort of not thinking straight.

    Thanks!


  • @Turbo glad we got it all working for you!