Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Changing MangoES to use DHCP via USB key not working


  • Mango software version (core): 3.5.6 (current at 28/5/2019)

    I have tried to change a couple of MangoES's from Static IP (on eth0, IPv4) to DHCP. When I plug in the USB stick, the LED's flash on then off. I then power cycle the device, but the settings aren't changed. I have successfully used the USB stick to change from dhcp to static, so I know the process works in general. I am using the same file - '\script-enabled\networking.properties'. The read_me file on the drive has an example for changing to static, but not one for changing to DHCP. It looks pretty straightforward - I believe I have followed the syntax rules in the READ_ME file, but can't get it to work. If I go into System Settings -> MangoES configuration on the old UI, I can manually change to dchp without a problem. I checked the mango log files, but couldn't see anything logged about this. I have attached screenshots of files and config I'm using.

    The settings I'm starting with:
    0_1559264292575_Before - static IP.JPG

    The file I'm using to change to dhcp - does NOT work:
    0_1559264628935_change-to-dhcp - this does NOT work.JPG

    Another file I have tried with more fields - still doesn't work:
    0_1559264638262_change-to-dhcp with all fields - this does NOT work.JPG

    This is a file I use to change the other way (ie to a static address) - it works fine:
    0_1559264644829_change-to-static IP - this works.JPG


  • Hi andrewh,

    There should be an output log in the MangoES/ directory on the USB utility, but it looks like there may not be a message if there was an error status on attempting to set it to DHCP. The interesting thing about what you report is that the USB utility uses the scripts from the ES Configuration module to make its changes to the operating system. So, I would expect it to work if the ES Configuration module is and the utility is running. Can you share the output of the /MangoES/esUsbUtility-{date}.log file?


  • I checked the USB key and it does NOT have a /MangoES folder. I checked another key and it does have the folder. I have created a /MangoES folder on the key and will try again tomorrow. I'll let you know what happens.


  • Without that folder I would have expected the USB utility script to abort due to an improper file structure.


  • This is working now. I think the main issue was simply that 'DHCP' needs to be upper case. Other things I noticed were that the script takes about 1 minute to complete, the LED's do NOT go off (even after about an hour) and the mango needs to be rebooted (it does not need a reboot when changing to a fixed IP address).