Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Did something change in the data importer?


  • I'm fairly certain that I used to be able to click on the Export CSV for a data source, open in excel, make some point changes and then copy paste the result in the config import section, select CSV and import that. It doesn't like that anymore however, it claims it can't find the first column

    Invalid header format, first column must be modelType.
    

    Am I wrong? Here's a snippet of the data I'm trying to import

    modelType	xid	name	enabled	deviceName	dataSourceXid	readPermission	setPermission	templateXid	unit	useIntegralUnit	integralUnit	useRenderedUnit	renderedUnit	pointLocatorType	dataType	settable	relinquishable	isMapping	toXid	fromIdentifier
    DATA_POINT	ACCT_7031675000_kWh	ACCT_7031675000_kWh	TRUE	KRP - 11 Hines Rd	DS_HOL_Data_Import					FALSE	s	FALSE		PL.DATA_FILE	NUMERIC	FALSE	FALSE	FALSE		ACCT_7031675000_kWh
    

  • Looks like your excel might have changed the CSV format to tab delimiter. Open in a text editor to confirm that if it is comma delimited.

    Edit: Change to using office libre and you'll never struggle with CSVs again :)


  • Hmm that's interesting, that seems to be a new behaviour for Excel 365 cause my process hasn't changed, I always used to use Excel. Curious...
    K thanks, at least there's an explanation :)