Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Bulk Datapoint Editor Import from CSV file - tags linked to AB plc don't return data


  • I have an Allen Bradley PLC … I set up the datasource to link to it and I created several datapoints to get data from this plc and these all work. I can link the datapoints to gauges on my dashboard and they display the data correctly.

    In my system I have three devices and all three have the sensors and devices attached to them. So I exported (used the bulk datapoint editor to export the file) the datapoints that I created for my PBR-01 in the data sources editor (these work) ...then I used excel to edit the CSV file to include a PBR-02

    I have attached a screen shot of a simplified version of the CSV file (the one I exported, modified and imported has more data points than this .. I cut it down to just two points for simplicity of posting)

    You can see the original PBR-01 data point is the first line.
    The second line is a copy of the first line … I edited only the highlighted fields

    0_1556209378549_a78014f3-911c-49f3-8bd5-708c50ec2cfb-image.png

    I then imported this new CSV file using the bulk datapoint editor. It imported with no errors and I can see all of the new datapoints and they are all showing the link to the appropriate PLC tag. These new datapoints unfortunately do not retrieve data.

    0_1556209592464_d345e931-56f5-40ac-99da-9d72015480f6-image.png

    Here is a screen shot of my dashboard. The top gauge is linked to my PBR-01 datapoint that I created using the datasources data point editor. The bottom gauge is linked to my PBR-02 datapoint that was created by copying the PBR-01 row in my CSV file and changing the fields as shown above then importing using the buld datapoint editor.

    You can see that the lower gauge shows a ? and no needle for the value. Looking into the datapoint history also just shows ?

    Not sure why this isn't working. I have looked at this several times and can't see why it doesn't work.


  • Interesting. Have you tried disabled and re-enabling the data source? Can you try comparing the two data points on the data sources page and checking the properties on the new data point were all set correctly. Maybe also export the new point as CSV and compare the rows to what you imported.


  • I had not tried disable and enable on the datasource. I did just try that now and it still does not work.

    I exported what i have now and have attached a screen shot of the csv file. I transposed the data to make it easier to look at and i made a conditional format to indicate any fields that are different.

    0_1556212179729_745fcb57-7712-4ccd-a8a2-630e201daae9-image.png
    0_1556212188014_605f2d11-ddb8-46e4-bed7-281c320a74ad-image.png


  • Hi

    Forget about the dashboard for now. Can you show us what the data point details pages shows for the new point.
    Are there any errors or alarms on the data source?


  • Thanks .. looks like I found the issue ... I am still running a trial version. One of the Urgent Events says that the license only allows 5 data points from this data source.

    0_1556287532245_1d791c87-b2f0-4505-87c7-c51c19a71e31-image.png
    0_1556287772231_13753380-04a7-4484-a4fb-9098f345cc12-image.png


  • Hi wallobee, welcome to the forum!

    Are you evaluating Mango for a commercial deployment? We can issue you a trial license that would temporarily allow your to exceed the license restriction. You can email support@infiniteautomation.com with a description of what you need to evaluate and how long you need it for.