Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Dashboard graph not displaying when REST calls timeout after 30 sec


  • When attempting to display a dashboard containing a graph for one or more data points, and a data point has a large amount of data to display based on the date/time range chosen (eg 30 second samples for 2 months), it is necessary to select a rollup type to avoid the browser overloading with too much data. "Simplify with target" generally works well, although in this situation, the server often takes more than 30 seconds to calculate the data points and the browser times out after 30 seconds. The dashboard then hangs, and the graph is not displayed or refreshed.
    In chrome, using Developer Tools -> Network, the status of the web service call changed to '(cancelled) after 30 seconds and Size = 0B.
    In Firefox, the call shows a result if it returns within 30 seconds, but never updates or shows a result if it hasn't returned within 30 seconds.
    See screenshots.
    My research indicates we should be able to change the default timeout in Firefox, although I haven't found which setting this is.
    I don't believe this can be changed in Chrome.

    I am looking into changing the data point default to Simplify with tolerance, which seems to be faster, but I would still like the graph to work where the data takes more than 30 seconds to retrieve from the server.

    Can anyone advise a way to get around the 30 second limit, or even display an error message asking the user to select a shorter time frame or something?

    Screenshots (Firefox then Chrome):

    0_1548811991810_REST timeout in Firefox.PNG 1_1548812400603_REST timeout in Chrome.jpg 0_1548812400602_REST call.PNG


  • @andrewh The timeout is configured from our code, its not something set by the browser. You can change the default timeout using a user module like so -

    define(['angular', 'require'], function(angular, require) {
        'use strict';
        const userModule = angular.module('userModule', ['maUiApp']);
        userModule.constant('MA_TIMEOUT', 60000);
        return userModule;
    }); // define
    

    PS I might increase the default timeout for point value requests in the next release.


  • Thanks

    Can you please let me know if you have increased the timeout?

    Thanks


  • Hi @andrewh we made the timeouts user configurable. They are on the UI setting page - 0_1575325028770_9ae4069d-b1e9-4bbf-83ba-1c81d44e4af0-image.png