Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • Our dashboards load fine over the LAN (rarely they also don't fully load on our raspberri Pis), but when trying to load them over a VPN connection remotely, they seem to not fully load. See the images below:




    Any ideas how to begin to investigate this?

  • Do you have any kind of proxying being used? If so you probably have to do something special in the proxy for web sockets.

  • Ok I just found a clue.

    When I open the dashboards with the administrative login, they load fine. However, when I try to load them with the auto-login user, they stop loading at some point.

    It may also have to do with the fact that the dashboards load full screen in the auto-login way, which does not load a sidebar.

    PS: We use OpenVPN, and from my understanding there is no proxy involved.

  • Could it be a permissions problem where the auto login user doesn't have read access for some of the points?

  • I'll investigate the permissions issues and get back to you, but as I mentioned earlier, they do mostly work fine in the local network. It's a bit mysterious to me.

  • If you open up the Chrome developer console, then look under the Network and Console tabs, you'll be able so see what isn't loading, which should give you a good hint about the source of the problem.

  • You also might have a look at the VPN MTU settings, as your problems seems related to that.

  • Everything seems to be working perfectly now, so there are no errors.

    So I'm going to rule out anything on the Mango side, but I'll look into the MTU settings as soon as I figure out where they are.

    Thanks for the help.