Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Funky web issues with the new updates


  • For our "LobbyHistorian" I get the following error:

    "Page Not Found!
    The page that you requested was not found. Please check your URL and try your request again, or start again from the login page."

    I tried deleting the contents of the /mango/work/jsp folder and that did not help. I also did not see anything in ma.log turn up at the time that I tried to access that folder.

    In addition, the point hierarchy from this mango is no longer pushed tot he Main Historian correctly via Persistent TCP sync. I had previously organized the new BACnet sources in a folder, and now they show up un-organized on the Main Historian.

    For our "22Historian" I get a Server Timeout error at the top, when accessing the Data Sources page, though I did not notice any issues with usability of the actual page.


  • Hi Mihai,

    Oh no! What version of the Core are you using? We had to release 2.8.4 yesterday because there was a bug with publishers. i would think it could be related to the issues with the point hierarchy. Your organization of the point hierarchy may exist in one of your configuration backups, so hopefully you can import it from a Mango/backup/Mango-Configuration.json backup to save yourself that effort.

    I'm not sure I understand what URL it is that could not be found. You're saying you clicked the edit pencil for the publisher and saw that? What's the URL after the host that you had an issue with?

    The timeout on the 22Historian seems like it could happen after you delete your JSPs, since it'll have to recompile them to open that page. But, it shouldn't say that every time. I wouldn't think it's an issue but let us know if it continues.


  • Seems like the second time deleting the folder contents has resolved it. I just didn't realize that doing that a second time would work. I thought maybe it was a bigger problem.


  • Best to hold off on 2.8.4 right now. Someone deactivated it in the store as we think we located the cause of so many users having to delete their Mango/work/jsp directories. We'll probably be releasing a cleaner 2.8.4 today.


  • Well as far as its core functionality, mango hasn't had a problem yet, and I'm done messing around with the web portion of it for the time being.

    Glad to hear it's being resolved =)


  • Okay, 2.8.4 is available.


  • I can't upgrade my modules because the modules page isn't working. I tried deleting the folder again.

    What's the next step?


  • I got lucky this morning with deleting the folder /work/jsp and I was able to get to the modules page to upgrade.


  • How strange. A user has reported the need to delete their work folder and restart after getting an error caused by the JSPs. It shouldn't be necessary generally, though.


  • I also had an inodes full issue and I used this command to list out inodes:

    find / -xdev -printf '%h\n' | sort | uniq -c | sort -k 1 -n

    I found it easier than what was on this thread.

    It was the same folder that was causing problem var/spool/exim4/input.


  • Thanks for sharing the steps in your solution!