Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Mango system updates data values slowly


  • We found that Mango system 2.4 updates data values slowly from the day before yesterday. Description as following.

    1. Only MODBUS serial data sources which have lots of data points updates slowly, BACnet and Modbus IP data sources are running normally.
    2. The MODBUS serial data sources which have less data points updates normally.
    3. When we copied those abnormal data sources to a testing mango on a laptop machine, they updates normally.
    4. Attached an alarm message to you.

    Could you please help to resolve this problem? Thanks so much.

    Attachment: download link


  • It's hard to say without knowing more about the whole system. Those alarms are just saying that the slave device is not responding with in the time out period and after how ever many retries you have set.

    You can go to edit the data source and click on the "Runtime Status" to see how many, if any, polls are being discarded.

    You can also use the Mango Internal Data Source to monitor all the internal aspects of Mango which would be helpful for us to know. Attached is a JSON configuration for the Internal Data Source incase you have not already set it up.

    If Mango is running out or resources then things could slow down. If you have devices timing out that can slow things down as well as each time a device times out it causes retries to happen and if this takes longer than your poll period then you'll end up with discarded poll.

    Attachment: download link


  • An internal data source was created in the Mango system before.

    please see attached screenshot of the internal datapoints.

    thanks.

    Attachment: download link


  • I see you have a lot of unacknowledged events. I would recommend purging your events table and see if that speeds things up. I seem to be sharing this thread a lot lately:
    http://forum.infiniteautomation.com/forum/posts/list/1796.page

    If you can use the SQL statement to delete everything in the events table. Go through your settings and turn things to Do Not Log that you don't need to minimize the number of events that are being created.

    Let me know if that helps,
    Joel.


  • Hello, Joel. This is Marc working with Mebius.
    We have acknowladged all alarms and then deleted all from EVENTS table using the SQL statement.
    Unluckily it didn't work much. Maybe our trouble comes elsewhere.

    We did find something. As you and your colleague Phil know, we are using combinations of scripting data source, serial test data source and meta data source to send and receive messages through serial ports.
    There are more than 20 combinations of these data sources in our mango system now.

    1. When these 20+ combinations are disabled, other 100+ data sources and publishers can work at a normal speed.
    2. When these 20+ combinations are enabled, with periods of 20 seconds on scripting data sources, the whole mango system slow down. All 120+ data sources updates slowly. And all publishers become slower and slower until they stop to publish any data.
    3. After we change the periods to 5 mins on scripting data sources, the publishers can work normally, but data sources are still slow. We got stuck when opening the "datasources.shtm" page, several minutes after enabling them.

    We need a way that provides both shorter periods and normal speed updates.
    Also we see a very high memory usage of mango, up to 1.4G. Is that because the total number of data sources, or something else?

    @JoelHaggar said:

    I see you have a lot of unacknowledged events. I would recommend purging your events table and see if that speeds things up. I seem to be sharing this thread a lot lately:
    http://forum.infiniteautomation.com/forum/posts/list/1796.page

    If you can use the SQL statement to delete everything in the events table. Go through your settings and turn things to Do Not Log that you don't need to minimize the number of events that are being created.

    Let me know if that helps,
    Joel.


  • Hi, thanks for the information.

    We have identified some improvements in the serial data source. Take a look at this thread: http://forum.infiniteautomation.com/forum/posts/list/15/1813.page there is an updated serial module you can download and test at the bottom of the thread. If you could also send your scripts we can take a look at those but I think upgrading the serial data source would be a good first step.

    Thanks,
    Joel.