Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • Hi all,

    I am new to mango and I am struggling to get the license to register. I have down loaded the license file and placed it in c:\mango (where my install is). When then try and restart instance I get an error (please see attached.)

    FYI System is win7

    Attachment: download link


  • This looks similar to a previous error. Can you try upgrading to core 2.0.2? If you are already there, can you post your license file?


  • Hi,

    Thanks for the reply. The version is ma-full-core-2.0.1, but I can not find a 2.0.2 using this link http://infiniteautomation.com/index.php /download.html. Is there another download location?

    Thanks


  • Ah, right. MA updates are available here: http://m2m2.serotoninsoftware.com/


  • Thanks again for the reply.

    I've tried that, but still the same I'm afraid (exact same error code). I'm using Java 1.7 if it makes a difference?

    This is my license

    <license>
    <core>
    <guid>2-e4913bd1-1622-405c-a4fb-3095a7886b08</guid>
    <distributor>IA</distributor>
    <domain>localhost:8080</domain>
    </core>
    <modules/>
    <signature>
    KhO+3GOPimNmW+N3v2phjhTpkaWB02nlu9NsdepWMCCjVGaM5xOBBkG35AMknppF
    AaNFKXGxyUgtty496QB3Punn3E0Blv3+Hkz1PIUjcSnnMYFrOvPJxVQ8Ada2hdhp
    RNXoDWzzha10hk9t80ZVE5vCdK3ysI8VPTl8DLoG3cAbV/4U/4+qnxENUUxwUO/a
    wSE0qH4CbZHkClqAlEt/BgGybYCxJ+l3IiF0FQ4Evo9ijTbkLIve6pEF0SwFAu+x
    Rf9nCMBXSv2TblVFDZko6jhtWppg7czMo06+sI8AKNrSTRWY12Hvc+WU8yAQYPSJ
    Olis+JkvanOGStd9nHTu8aK+zY1HqVARfoApbxdDTf5AR2ACOcl9UkHbjQfZKTEU
    rJyxmljNwc8Cq9dUZpThK4WZe8Ibi839oCpCJWKjZ5JhQn0tqPb8awUrS/LqVbwK
    7f5Z2uRgHyjCEwiiMM2lmetH/yDk8lyel6Agkb1RZrCU5xDwpltVsusLMXq9JW27
    MOf3htQeoBUnL+usj6KmdHtgIw/Kfd6ObeMyj4caMWGSvkOtI5FMvXrrEaM39OLZ
    H6/1884OGM/EP70qbXf75T9+NYLAIf1do4WJ+18KMmQObYZCvi/i3B2CfUFc2I6Y
    MSj2QiOxjqiEb69gNvDv3IpA/IKr+qkBwrtO8KrDsqU=</signature>
    </license>

    Thanks


  • Java 1.7 may cause some problems, but not what you're seeing at the moment. I've updated the 2.0.2 core. The version number is the same but the distro size should be different at least. Can you download and try again?


  • Hi,

    The new distro worked and I can now open mango with the license file in place, thanks. I'm sorry to ask again, but I have loaded several modules restarted the instance and all the modules are saying not licensed for use. Please see attached. I have installed java 1.6 but this hasn't helped.

    Thanks in advance

    Attachment: download link


  • At the MA store you need to select the license type that you want have in your license file, even if there is only one type. If you do not make a selection, there will be no section in the license file for that module, and you will see that message on your module list.


  • Thanks for the continued support. I didn't see the radio buttons. So to the next problem....

    I click on data sources and I think I should have the virtualds (apart from others) source but it's not there, just the egg timer. I also click on the point hierarchy and I get the egg timer and I can't add a new point. Any suggestions please?

    Edit - Please see attached I've notice some warnings in the script. Is this helpful?

    Attachment: download link


  • Hi,

    I'll be available tomorrow after 10 am Colorado time on Skype we can do a screen share if you want to get this all working for you.

    Thanks,

    Joel.

    Skype: Infinite.Automation