Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • hi there !

    I'm playing with m2m2 + modbus (so no license for core/modbus) and I don't manage to use more than one modbus point.

    I'm doing the following:

    • create a modbus data source
    • tests: module scan, read data, point locator test
    • create a point (coil status) - name: y11

    everything seems to work ; but then, if I add a 2nd point (name: m11), I get "illegal data value" alarms for that point, while the 1st one (y11) is working OK.
    it's not a problem with the point config itself since if I first define m11 then y11, the illegal data value is now for y11 while m11 is working.

    tried with 1.1.0 as well as 1.2.0rc.

    is that a limitation of the trial mode ?


  • No, there is no such limitation in the module trial mode.

    Can you provide an export of the points? Also, when you test them with the data source tools, what values do you get back?


  • thanks for the quick reply...

    here's the export (with the data source as well).

    this m2m2 instance is only for tests and this specific data source + 2 points, so no problem if you want me to do some tests / brake things.

    forgot to mention that to iron out a problem with the modbus device itself (Delta electronics/IFD9506) I tried reading the coils with libmodbus (on linux) as well as Delta's own software and everything is OK.

    Edit:

    1/ results of the read data test / coil / 2050 + 10:
    2050 ==> false
    2051 ==> true
    2052 ==> false
    2053 ==> false
    2054 ==> true
    2055 ==> false
    2056 ==> false
    2057 ==> true
    2058 ==> true
    2059 ==> false

    2/ results of point locator for coil 2059
    Result: false

    Attachment: download link


  • For fun, try checking "Contiguous batches only" and saving the data source.


  • it seems it fixed it, no new alarm for 10 minutes.

    I thought about that option when reading the changelog of 1.2.0rc, but 1.1.0 had the same problem so I dismissed it.

    thanks - I will continue testing... ; feel free to ask if you want me to test that setup again with in case you patch something.