Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Sensatronics EM4 Datasource & Points


  • I'm having some trouble setting up my Sensatronics device as a datasource. I have it setup as a HTTP Retriever with this address: "http://10.0.0.50/data" Which gives me this error:

    "Error retrieving page 'http://10.0.0.50/data': org.apache.commons.httpclient.ProtocolException: The server 10.0.0.50 failed to respond with a valid HTTP response"

    I'm assuming this error is due to the fact that there are no HTTP headers in the source code.
    This is all that is in the source code of that page:

    F|83.3|27.9|-999.9|90.6|26.9|-999.9|78.5|35.7|-999.9|83.4|31.7|-999.9

    [url=http://www.sensatronics.com/downloads/programmers_guides/programmers_guide_em1.html]Here is a link to the programmers guide for the monitor.
    Not really sure what to do at this point.


  • What do you see when you use a browser to go to http://10.0.0.50/data? What you see in the browser is what Mango sees.


  • Try it for yourself, paste what is below in notepad and save it as an html file on your web server and try to use it as a data source. If it works for you then I must have something else wrong. This is literally all that is in the source of the page and it is all that I see on the page:
    *
    F|83.3|27.9|-999.9|90.6|26.9|-999.9|78.5|35.7|-999.9|83.4|31.7|-999.9
    *


  • It works fine. Can you please answer the question though? When you click on the green arrow beside the URL field, what happens?


  • Yes, when I click the green arrow I get a new tab with that string in the body and source code of the page.

    Ok there must be something up with the built in server on the device. Because when I copied that string to a new page on our intranet server it worked for me as well. I'll check with the mfg.

    In the meantime, I tried to use the static page that worked (http://10.0.0.240/temp_rh_test.html), however it's showing no data. I only want to capture the number between the first two bars "82.6"
    Here are my point details:

    Name: primer temp
    Data type: Numeric
    Value RegEx: F | (.*?) | 'This was based on the help example
    Ignore if missing: unchecked
    Number format: 0.0 F
    Time RegEx: Empty

    I'm guessing that I messed up the Value RegEx, but you tell me.


  • The pipe is a special RegEx character. You need to escape it. Try this instead:

    F\|(.*?)\|
    

    Also, the number format is for parsing purposes only, so don't include any ornamentation (i.e. the "F"). You can use a text renderer on the point to add a suffix like that.


  • UPDATE!

    After working for some long hours with the mfg :(, I determined that it might work better if I use SNMP....

    Success!!! :D

    In about 10 minutes I had the whole thing working better than our current software! I'll be playing with it over the weekend and most likely complete the conversion to this next week.

    I do have another question, but I think it might belong in another category or at least it's own thread.
    Thanks again for all the help!