I´m using mango v3.7.4 , and I confugure a http json receiver data source. I set HTTP JSON receiver point with "/" to receive all json document in alphanumeric format, but when I receive the post with the json document, the point fill with null data and no the whole document.

This is the datasource configuration:

{
"dataSources":[
{
"xid":"DS_DAI_JSON_receiver",
"name":"DAI_JSON_receiver",
"enabled":true,
"type":"HTTP_JSON_RECEIVER",
"alarmLevels":{
"SET_POINT_FAILURE":"URGENT",
"JSON_READ_FAILURE":"URGENT"
},
"purgeType":"YEARS",
"setType":"PUBLISHER",
"dateFormat":"DATE_FORMAT_BASIC",
"receiveType":"JSON",
"deviceIdWhiteList":[
""
],
"ipWhiteList":[
"
...*"
],
"setPointUrl":"http://localhost:8080/httpds",
"editPermission":"",
"purgeOverride":false,
"purgePeriod":1
}
],
"dataPoints":[
{
"xid":"DP_json",
"name":"json",
"enabled":true,
"loggingType":"ON_CHANGE",
"intervalLoggingPeriodType":"MINUTES",
"intervalLoggingType":"INSTANT",
"purgeType":"YEARS",
"pointLocator":{
"dataType":"ALPHANUMERIC",
"deviceIdentifier":"",
"deviceIdentifierKey":"",
"timestampIdentifier":null,
"binary0Value":"",
"includeTimestamp":true,
"parameterName":"/",
"setPointName":"",
"settable":false
},
"eventDetectors":[
],
"plotType":"STEP",
"rollup":"NONE",
"unit":"",
"simplifyType":"NONE",
"chartColour":"",
"chartRenderer":{
"type":"TABLE",
"limit":10
},
"dataSourceXid":"DS_DAI_JSON_receiver",
"defaultCacheSize":1,
"deviceName":"DAI_JSON_receiver",
"discardExtremeValues":false,
"discardHighLimit":1.7976931348623157E308,
"discardLowLimit":-1.7976931348623157E308,
"intervalLoggingPeriod":1,
"intervalLoggingSampleWindowSize":0,
"overrideIntervalLoggingSamples":false,
"preventSetExtremeValues":false,
"purgeOverride":false,
"purgePeriod":1,
"readPermission":"",
"setExtremeHighLimit":1.7976931348623157E308,
"setExtremeLowLimit":-1.7976931348623157E308,
"setPermission":"",
"tags":{
},
"textRenderer":{
"type":"PLAIN",
"useUnitAsSuffix":false,
"suffix":""
},
"tolerance":0.0
}
]
}

The json receive whith the HTTP receiver listener is like this:

[
{
"type": "1",
"data": {
"image": null,
"video": null,
"idDetector": "CAS-97",
"idIncident": "CAS202010053",
"status": 1,
"place": null,
"typeIncident": 1
}
},
{
"type": "1",
"data": {
"image": null,
"video": null,
"idDetector": "CAS-96",
"idIncident": 0,
"status": 0,
"place": null,
"typeIncident": 0
}
}
]

I thing it could be a bug, other json pointer notation like /0/data/idDetector works fine.

Thanks !