Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Excel Report Not Running at Correct Time


  • Hello,

    Yesterday we created a new Excel report and scheduled it to run at 1am every morning. When I checked my mail this morning I was surprised to see that it ran at 4:05:59 am EST.

    I've read the following post in the past and have experienced timezone settings affecting the job timing in the past, but believe that should not be the case now. https://forum.mango-os.com/topic/3506/use-of-cron-to-schedule-reports/2

    Here is some additional info as well as screenshots:

    • Server timezone is UTC

    • My local timezone is EST (5 hour difference)

    • The Excel report is scheduled to run at 01 hours each day
      023329a6-058d-4b17-9c40-f6b829299293-image.png

    • I am using the property file in the overrides folder to set the Mango timezone to US/Eastern
      0717b45e-f580-432e-8b46-e648bf903222-image.png
      35614ffe-1094-4344-ba49-50e5c54cc927-image.png

    Do you have any ideas as to why the report would have run at 4:05:59 am this morning and not 1am? It doesn't seem to have anything to do with UTC since the report ran just over 3 hours late, and UTC is 5 hour ahead of EST.

    0ad57531-5c6b-4ae8-a95b-9c475f2b4655-image.png

    Any help is appreciated.

    Thanks,
    Chad


  • I would check the work item priority for Excel reports in the System settings area.

    Administration --> System settings --> Excel reports

    The low priority pool generally has 1 processing thread in it (which can be configured in the thread pools system settings) and this means any task put in that pool will run when the thread is free to do the work. If you have many low priority tasks running around 1AM it will sit in a queue until it is processed.

    You could either increase the low pool size or have it run in the medium priority pool.


  • Terry,

    Thanks for the suggestion, I'll try that now and let you know how it goes.

    FYI, last night/this morning it ran at 2:03am EST, so sooner than the previous day, but still an hour off. Hopefully you're onto something with the priority.

    Thanks,
    Chad


  • Terry,

    Updating the priority seemed to do the trick. The job ran on time this morning.

    Another factor that I'm sure contributed is that we didn't realize our CPU was pegged for a couple days and had to restart Mango to clear that up. (Different post created for that issue...)

    Thanks,
    Chad