Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Modbus Master alarm message: CRC mistmach!


  • Hi,

    Can you help me know the meaning of a message in Mangoand how could I solve it.

    I am reading data from a clp Altus, configured as Modbus RTU slave. I created a data source called the Cell and various datapoints using Holding register, two byte signed integer.

    When I turn the first datapoint, no problems, no menssagem alarm, but when I start to enable the following datapoints (eg offset: 30, 32, 34) leaves the following urgent message:

    19:05:25: 'Cell': Exception of modbus master: CRC mismatch: Given = 0, calc = 28752

    Thanks

    Regards,

    Nicole


  • Hi Nicole,

    Are you able to capture data stream traces from your device (both request and response if possible) and send them over? It would help in figuring out what is going on.


  • Hi,

    Yes, I can read and write data from SCADA. To solve the problem, I tried to change my memory addresses, one after the other(because they were two and two, that is, for example:% M0052,% M0054,% M0056 etc,) thus: %M0052,% M0053,% M0054, etc but continues giving the same mistake now with another value, being able to read two addresses clp without following message appears:

    Célula': Exception from modbus master: CRC mismatch: given=256, calc=28752 ,

    Inactive time: 16:39:38 - Returned to normal

    OBS: EVERY SECOND RETORNED TO NORMAL.

    Recalling the previous message: 'Cell': Exception of modbus master: CRC mismatch: Given = 0, calc = 28752

    And although it may read the data that I need, that message goes out forever, which indicates that something is wrong and that surely something must be set wrong, considering that my experience with Holding register is rather low, which does not happen with "coil "because I know how it works!


  • Check the modbus configuration and use this program http://www.modbus.pl/MTester.htm to get the data traces on its communication spy.


  • I tested with mtester and it worked, gave no communication errors, data traces ok, but when I test with mango, still the same problem.!


  • It's often not very helpful to repeatedly say that it doesn't work. Can you please provide some more information. It may appear to work fine with mtester if that program simply suppresses anything that doesn't look right. Modbus4J is more forthcoming. Perhaps your next post can include some trace information such as has been suggested multiple times.