Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Modules not loading after including them in git/ma-core-public/Core/web/modules


  • I recently set up my development environment in Eclipse and wanted to include a bunch of modules including the dashboardDesigner and dataFile modules that weren't part of the repository. Unfortunately, I can't get them to load when I launch my instance of Mango. I included the files I downloaded from the store in the git/ma-core-public/Core/web/modules directory as @phildunlap mentioned to do in an older post but they don't appear when I launch the core. I was hoping someone might be able to provide some insight into what I might be missing.

    Thanks,

    Gord


  • I may have solved my own problem. I am running version 3.8.0 and the logs say the modules need a core version of 3.7.


  • Alright, I'm stuck. I tried pulling the 3.7.x branch rather than the main branch and following the same process for setting up the dev environment in Eclipse but when I go to build the project I get to the log in page but won't let me log in. It tries to take me to /ui/agree-to-license but stays on the log in page and says "You are already logged in as admin. Go to the main UI."

    In the logs it seems to be having trouble connecting to api.

    I'm wondering if I am using the right branch?


  • Final Update: It took some fiddling but installing the 3.7.x branch worked. All modules are loaded can now but placed in the git/ma-core-public/Core/web/modules directory and loaded into the build. If anyone is interested, I created documentation for the process I used to set up Eclipse for version 3.7.x. Feel free to reach out and I can share it.