Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • OS Windows 7 Home Premium 64-bit
    Mango version 3.7.7
    graphicalViews 3.7.0
    webrowser Firefox version 75.0 installed last April the 8th
    Mango API 3.7.0
    Mango UI 3.7.3

    Greetings,

    I am a recent user of Mango, still evaluating/ learning about it. I am very interested on providing scada capacity to my Arduino setup, and though being only a mildly capable Arduino user so far Mango seems very fluent and easy to use.

    Now, here comes my first difficult problem so far: Since this morning, and (apparently) with no action from my side, Dashboard Designer does not show any graphics whatsoever. I have a very simple system input with 4 variables from Modbus Arduino via USB. Data capture and storage works flawlessly. I very quickly started generating real time gauges from my data points and generating views of them. I have started learning about more complex historic data graphics, but now I can't seem to see graphics any more. I can see and edit code, either in the dashboard designer working space or in the edit pages area, but no graphics at all.. The graphic design area is black and empty, I was able to see again the graphic working area and its elements if I restored a previous revision story, but now that does not seem to work any more.

    One more thing, the system is very self-contained, just a laptop connected to an Arduino on my desk, with no networking at all so far (other than internet for the laptop via wifi).

    Please tell me, is there anything wrong with my Mango installation? is this some limitation of the evaluation licence?

    Thank you for your time and attention.

    Javier


  • @javiparei Welcome to the forum!
    Before we can give you any answers, can you take a look through your [mango install dir]/logs/ma.log to see if there are any errors?

    Better yet, paste it here between some code tags so the infinite folk can take a peek.

    Fox


  • @javiparei
    i think you have bugs in your markup code. that is what i have seen during my programming.
    Just restore your prior version and do it again.