Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

JSON Data Point Format - Solved.


  • Hi,
    just in case anyone intested - the json value pointer' field should be '/observations/data/0/apparent_t

    I am trying to setup a JSON retriever data source from a weather service and its JSON file path is below:
    http://reg.bom.gov.au/fwo/IDV60901/IDV60901.95936.json
    As a test, I want to retrieve the value of 'apparent_t' as pointed out in below partial json file and screenshot:

    {
    	"observations": {
    		"notice": [
    			{
    				"copyright": "Copyright Commonwealth of Australia 2019, Bureau of Meteorology. For more information see: http://www.bom.gov.au/other/copyright.shtml http://www.bom.gov.au/other/disclaimer.shtml",
    				"copyright_url": "http://www.bom.gov.au/other/copyright.shtml",
    				"disclaimer_url": "http://www.bom.gov.au/other/disclaimer.shtml",
    				"feedback_url": "http://www.bom.gov.au/other/feedback"
    			}
    		],
    		"header": [
    			{
    				"refresh_message": "Issued at 11:11 pm EST Sunday 22 September 2019",
    				"ID": "IDV60901",
    				"main_ID": "IDV60900",
    				"name": "Melbourne (Olympic Park)",
    				"state_time_zone": "VIC",
    				"time_zone": "EST",
    				"product_name": "Capital City Observations",
    				"state": "Victoria"
    			}
    		],
    		"data": [
    			{
    				"sort_order": 0,
    				"wmo": 95936,
    				"name": "Melbourne (Olympic Park)",
    				"history_product": "IDV60901",
    				"local_date_time": "22/11:00pm",
    				"local_date_time_full": "20190922230000",
    				"aifstime_utc": "20190922130000",
    				"lat": -37.8,
    				"lon": 145.0,
    				"apparent_t": 8.7,
    				"cloud": "-",
    				"cloud_base_m": null,
    				"cloud_oktas": null,
    				"cloud_type_id": null,
    				"cloud_type": "-",
    				"delta_t": 3.2,
    				"gust_kmh": 9,
    				"gust_kt": 5,
    				"air_temp": 11.2,
    				"dewpt": 4.0,
    				"press": 1022.3,
    				"press_qnh": 1022.3,
    				"press_msl": 1022.3,
    				"press_tend": "-",
    				"rain_trace": "0.0",
    				"rel_hum": 61,
    				"sea_state": "-",
    				"swell_dir_worded": "-",
    				"swell_height": null,
    				"swell_period": null,
    				"vis_km": "10",
    				"weather": "-",
    				"wind_dir": "NNE",
    				"wind_spd_kmh": 6,
    				"wind_spd_kt": 3
    			},
    

    0_1569158651779_Screen Shot 2019-09-22 at 11.23.01 pm.png

    below is my data source setting, since i am not sure about the setpoint part, I have used the same url
    0_1569158845698_Screen Shot 2019-09-22 at 11.26.04 pm.png

    Now comes to the data point part, I tried in the 'json value pointer' field with '/observations/data/apparent_t/0' (i tried a few other path as well but no luck)
    but it gave out an error shown below:
    0_1569159176158_Screen Shot 2019-09-22 at 11.32.46 pm.png

    Can I have some direction as what I have done wrong here?

    Thanks.


  • Hi cwangv,

    It sounds like you figured it out based on the bolded comment at the top? Maybe a second post would have been more straightforward, but thanks for sharing that it was resolved / the resolution you found.