Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Help with 3.6.6 UI Menu and More


  • Hi, everyone. I was changing menu items levels in the new UI (didn't do anything through ssh or Webmin) when a weird problem started. Look into the linked topic for more info.

    @jared-wiltshire said in Help Using <ma-map & <info-window:

    @jflores13 said in Help Using <ma-map & <info-window:

    Tried powercycling the MangoES but nothing changes, still blank side menu and weird behaviour in general. Everything is taking way longer to load. Also, in the new data sources page, now my data sources are "not supported yet", not even the virtual data sources. I get multiple errors like this one when loading a data source's page:

    OK no idea why but it appears that it can't load the module Javascript files from the backend. Check your Mango instance CPU and memory usage and also disk space. Unless you are just on a shitty connection to the backend?

    See if you can get here - /ui/administration/json-store-editor/mangoUI-menu
    And post up the contents.

    And yeah maybe create a new thread about this.

    Okay, so I looked into those values, and according to the internal points:

    • The "CPU Total Load" went to a max of 30% when the problem happened, then started to go down slowly and stopped at around 2%.
    • Exactly at the time when the problem happened, the "MangoES Physical Memory Free" went instantly from a steady 600MB to 1474MB, then stabilized again around 1200MB after 2 minutes.
    • The Disk Space Remaining didn't change much; only went from 4,674MB to 4,671MB when it happened.

    Talking about my connection to the backend:

    • I didn't change my connection before and after the problem.
    • The device is in a local network via ethernet and I'm accessing the same subnet via an Ubiquity AP. Normally everything works great. I also have another MangoES with the older UI and core working and responding perfectly.
    • I can load that shared path sometimes, sometimes it doesn't load. My web browser struggles each time it tries. When it does load, besides the multiple errors, the contents of the menu are:
    {
        "menuItems": [
            {
                "name": "ui.settings.deviceConfig",
                "weight": 1001
            },
            {
                "name": "ui.settings.dashboardDesigner",
                "weight": 1002
            },
            {
                "name": "ui.settings.dataSources",
                "weight": 1003
            },
            {
                "name": "ui.settings.editMenu",
                "weight": 1004
            },
            {
                "name": "ui.settings.editPages",
                "weight": 1005
            },
            {
                "name": "ui.settings.excelReports",
                "weight": 1005
            },
            {
                "name": "ui.settings.fileStores",
                "weight": 1005
            },
            {
                "name": "ui.settings.haystackHistoryImport",
                "weight": 1005
            },
            {
                "name": "ui.settings.haystackPointImport",
                "weight": 1005
            },
            {
                "name": "ui.settings.jsonStore",
                "weight": 1005
            },
            {
                "name": "ui.settings.jsonStoreEditor",
                "weight": 1005
            },
            {
                "name": "ui.settings.maintenanceEvents",
                "weight": 1005
            },
            {
                "name": "ui.settings.modules",
                "weight": 1006
            },
            {
                "name": "ui.settings.snmp",
                "weight": 1006
            },
            {
                "name": "ui.settings.system",
                "weight": 2000
            },
            {
                "name": "ui.settings.systemStatus",
                "weight": 2000
            },
            {
                "name": "ui.settings.uiSettings",
                "weight": 2000
            },
            {
                "name": "ui.settings.users",
                "weight": 2000
            },
            {
                "name": "ui.settings.watchListBuilder",
                "weight": 2000
            },
            {
                "pageXid": "c74de623-f26e-4a51-9b37-bbf8729cb86c",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.plc",
                "url": "/plc",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "PLC",
                "menuIcon": "select_all",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"c74de623-f26e-4a51-9b37-bbf8729cb86c\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "2e705486-d6c9-48bf-a1ce-3aff3907f6f3",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.vav",
                "url": "/vav",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "VAV Control",
                "menuHidden": false,
                "weight": 1000,
                "menuIcon": "polymer",
                "template": "<ma-ui-page-view xid=\"2e705486-d6c9-48bf-a1ce-3aff3907f6f3\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "041f0777-b76e-44e3-967c-836e73af346d",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.zonas.sotano",
                "url": "/sotano",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Sótano",
                "menuIcon": "arrow_downward",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"041f0777-b76e-44e3-967c-836e73af346d\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "0b75adab-6b50-49d3-a9a8-e86683f52cc8",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.zonas",
                "url": "/zonas",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Zonas",
                "abstract": true,
                "menuHidden": false,
                "weight": 1000,
                "menuIcon": "pages",
                "template": "<ma-ui-page-view xid=\"0b75adab-6b50-49d3-a9a8-e86683f52cc8\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "35cedead-3036-4616-9969-13373808ed33",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.zonas.piso1",
                "url": "/piso1",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Piso 1",
                "menuIcon": "arrow_upward",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"35cedead-3036-4616-9969-13373808ed33\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "c8bf64e3-798d-4cbf-b137-593319c541a1",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.metasDiarias",
                "url": "/metas-diarias",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Metas Diarias",
                "menuIcon": "bar_chart",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"c8bf64e3-798d-4cbf-b137-593319c541a1\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "bec0d899-e5ef-4cd2-8959-e997e3622b40",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.zonas.plantaBaja",
                "url": "/planta-baja",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Planta Baja",
                "menuIcon": "exit_to_app",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"bec0d899-e5ef-4cd2-8959-e997e3622b40\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "bdf595a5-f040-4158-913a-e51a87f228b5",
                "linkToPage": true,
                "permission": "user",
                "name": "desarrollo.monitoreo",
                "url": "/monitoreo",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Monitoreo",
                "menuIcon": "",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"bdf595a5-f040-4158-913a-e51a87f228b5\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "13a3c19c-a327-4db9-ab3c-2325c313ecbc",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.mapas",
                "url": "/mapas",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Mapas",
                "menuHidden": false,
                "weight": 1000,
                "menuIcon": "map",
                "template": "<ma-ui-page-view xid=\"13a3c19c-a327-4db9-ab3c-2325c313ecbc\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "0e03d44e-7d8d-4197-8b0e-9775be047a53",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.mapasv3",
                "url": "/mapasv3",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "MapasV3",
                "menuHidden": false,
                "weight": 1000,
                "template": "<ma-ui-page-view xid=\"0e03d44e-7d8d-4197-8b0e-9775be047a53\" flex layout=\"column\"></ma-ui-page-view>"
            },
            {
                "pageXid": "e37982c2-5365-461a-b32e-ebafc52c38a4",
                "linkToPage": true,
                "permission": "user",
                "name": "ui.desarrollo",
                "url": "/desarrollo",
                "params": {
                    "dateBar": {
                        "rollupControls": true
                    }
                },
                "menuText": "Desarrollo",
                "menuIcon": "dashboard",
                "abstract": true,
                "menuHidden": false,
                "weight": 1000
            }
        ]
    }
    
    

    Nonetheless, my menu keeps showing up blank.
    The item that started the issue and that I later tried trashing was "Desarrollo".

    Anything else I should check?
    Thanks in advance!


  • @jflores13
    From that JSON, I tried deleting the "Desarrollo" bracket and changed the "name" in "desarrollo.monitoreo" to "ui.monitoreo" in the "Monitoreo" bracket.
    Now my menu does show up and the pages seem to load faster, but the menu has items that appear as "ui.settings.excelReports", or as "ui.settings.deviceConfig", but they don't work when I click them and they no longer have an icon.
    I'm just guessing what to do, though, so maybe I didn't do the right thing with the JSON.

    EDIT: I power cycled the MangoES and now everything seems to be working almost okay. I created a new abstract menu item for "Desarrollo" and then, using "Edit Pages", I created a new page, saved code in it, then used the menu JSON to put it under the "Desarrollo" item, but when I click it, it tells me the page does not exist.
    I change the name of the page from "ui.desarrollo.mapas" to "ui.mapas" and it instantly works again.
    What is going on?


  • @jflores13 Your menu structure JSON is screwed up for sure. e.g. you have a state defined with a name desarrollo.monitoreo but there is no parent item defined (e.g. one with a name of desarrollo). This will certainly make things not work correctly.

    I don't know how it ended up like this, whether it was as a result of something you did in the UI or if this is a result of you manually editing the JSON.

    Anyhow, I would recommend removing your custom JSON entirely. Go to /ui/administration/edit-menu and hit "Delete custom menu" then recreate the menu items using the UI.

    If the edit menu page is not working as a result of the screwed up JSON, go to /ui/administration/json-store-editor/mangoUI-menu and replace the JSON with

    {
        "menuItems": []
    }
    

    Key points to note:

    • "abstract" states appear as folders in the menu and cannot be navigated to directly
    • You can't create a state named desarrollo.monitoreo without having another state named desarrollo which should be abstract
    • A state which has a parent of UI will get the side menu and toolbars (these states are named with a prefix of ui.)
    • A state with a parent of "Root" will not get any side menu or toolbars

  • @jared-wiltshire

    Well, I posted the JSON as I found it, didn't manually change anything before posting it here.

    The parent item desarrollo did exist, and it had to be abstract because I just wanted to use it as a folder. The problem happened when I changed the level of that desarrollo item, being the parent of mapas, from "Root" to "UI", all of that done through the 3.6.6 UI. Exactly when I changed that, everything broke.

    At that moment, since everything made me think that page was the problem, I tried to change the level back to "Root", to see if that solved it, but the "Add/edit menu item" had already stopped working so I couldn't change it back anymore. Since I didn't know about the menu's JSON, my quick fix idea was deleting that desarrollo page, but that obviously didn't help.

    Then, that's when you pointed me to the JSON, so I copied it and posted it here as it was. As you say, it obviously looks screwed up, but I didn't screw it up myself, I actually had to manually fix what you are saying to make the menu work again.

    Besides, as I said in the last part, I also have another strange situation, because my pages don't load at all (I get an error at the bottom telling me the page doesn't exist) when the page's parent is a child of the "UI", and they instantly work when I make them a child of the "UI" directly. I already took those steps, deleted the custom menu and did a quick test before rebuilding the menu completely:

    • Created a new desarrollo page and checked "Show menu item as folder".
    • Set the level of desarrollo to "UI".
    • Tested another page that was "UI" level. It worked.
    • Changed that page's parent to desarrollo through the UI.
    • The page doesn't load anymore.

    NOTE: When I create a page, the radio buttons that should let me choose between "No content (folder only)", "Link to custom page", "External link", "Template URL" are fixed in "Link to custom page"; it doesn't let me change that.

    As always, thanks a lot, Jared.


  • @jflores13 said in Help with 3.6.6 UI Menu and More:

    Well, I posted the JSON as I found it, didn't manually change anything before posting it here.
    ...
    As you say, it obviously looks screwed up, but I didn't screw it up myself, I actually had to manually fix what you are saying to make the menu work again.

    OK, so it sounds like there is a bug in the UI menu editor somewhere.

    @jflores13 said in Help with 3.6.6 UI Menu and More:

    Created a new desarrollo page and checked "Show menu item as folder".

    Did you create a page or a menu item? These are two distinct things. If you are using the page editor or the dashboard designer you can add a menu item which is linked to the page you are editing. This is why you cannot change the radio buttons as you noted.

    @jflores13 said in Help with 3.6.6 UI Menu and More:

    The page doesn't load anymore.

    Define "doesn't load". Screenshots, errors console messages etc would be useful. Note that the URL will change if you change the menu item's parent.

    @jflores13 said in Help with 3.6.6 UI Menu and More:

    NOTE: When I create a page, the radio buttons that should let me choose between "No content (folder only)", "Link to custom page", "External link", "Template URL" are fixed in "Link to custom page"; it doesn't let me change that.

    To choose these other options create a menu item from the "Edit menu" page.

    If you are just trying to create a folder, you should do so via the "Edit menu" page and set it to "No content (folder only)".


  • @jared-wiltshire Ohhhh! How dumb of me.

    So I was screwing up, my bad practice since the previous UI, just created pages to add menu items and it used to work. Now I added the menu item properly, as "No content", and the page does load! Sorry about that.

    Nevertheless, about the bug in the UI menu editor, it does sound to me like there is one. Hope you can find it without too much hassle, please tell me if I can be of help, if I should try to recreate the error or whatever.

    Thanks a lot, Jared!


  • @jflores13 said in Help with 3.6.6 UI Menu and More:

    Nevertheless, about the bug in the UI menu editor, it does sound to me like there is one. Hope you can find it without too much hassle, please tell me if I can be of help, if I should try to recreate the error or whatever.

    Yeah it does sound like it. You probably should not be able to select "Show menu item as folder" when linking to a page either, that option was added for a reason which I wont get into but it doesn't seem to behave correctly when linking to a page.

    Glad you got it working.