Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • Heya,

    I copied an installation from one PC to another and when trying to start the copy, the boot up is stuck at 85%. I have tried restarting the app a few times and it stops at the same percentage each time.

    0_1564702757632_855430f9-13e2-48ff-821a-d69e8303d3fa-image.png

    I have copied installations around without issues but this is the first time I have seen this behaviour.

    I have cleared the browser cache without any success.

    Any suggestions? Trying to avoid having to build this installation from scratch.

    Thanks
    Ian


  • Your env.properties file is missing the store.url property, that and you don't appear to have the license installed for using the NoSQL - though that shouldn't stop it,
    Finally check your user permissions to access the H2 DB, I remember it being stuck at 85% for me due to a lack of credentials/ file access permissions


  • Hi Ian,

    Which JVM did you install? I have seen this with some JVMs on some devices, too. I recently had a client report this issue with a Raspberry Pi 3 on the latest Oracle Java 8, but it worked for him when he tried AdoptOpenJDK 11.


  • Hi Phil,

    For this deployment, we installed the openJDK:

    openjdk version "1.8.0_222"
    OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
    OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

    Funny enough we have been using the Oracle JDK for all our other deployments.

    Aside: we are concerned about using Oracle JDK v8 and the new licensing for future deployments.

    Thanks
    Ian

    Update: As suggested by Matt, I did review the permissions and ownership on the DB files (and all files) and they look correct. I also deleted the work folder. No change. I don't think it is an issue with permissions as the log shows the database starting, etc. I have commented out the store in other deployments and it has worked as expected.

    Perhaps one thing interesting is that even though the application appears stuck the log continues to be updated that the MQTT connection cannot be established. This would indicate at least the server is perhaps working as expected.


  • Data sources are started at 75% of the boot process, so by 85% they should be polling and recording data.

    What sort of machine, 64bit ARM?


  • Hi Phil,

    I will confirm the processor being used.

    I downloaded the 3.6.4 zip and deployed it into a separate directory. When the application is launched, it gets stuck again at 85% but I get the following error:

    INFO 2019-08-02T10:46:22,894 (com.serotonin.m2m2.rt.RuntimeManagerImpl.initialize:176) - Starting 0 Publishers...
    INFO 2019-08-02T10:46:22,894 (com.serotonin.m2m2.rt.RuntimeManagerImpl.initialize:188) - 0 Publisher's started in 4ms
    Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:807)
    at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:886)
    at com.serotonin.m2m2.view.ViewGraphicLoader.loadDirectory(ViewGraphicLoader.java:109)
    at com.serotonin.m2m2.view.ViewGraphicLoader.loadModuleGraphics(ViewGraphicLoader.java:56)
    at com.serotonin.m2m2.view.ViewGraphicLoader.loadViewGraphics(ViewGraphicLoader.java:44)
    at com.serotonin.m2m2.Lifecycle.imageSetInitialize(Lifecycle.java:1479)
    at com.serotonin.m2m2.Lifecycle.initialize(Lifecycle.java:363)
    at com.serotonin.m2m2.Main.main(Main.java:143)

    I didn't see this previously.

    Thanks
    Ian

    Note: this error is only visible on the console. It is not recorded in the ma.log


  • You can probably delete your Mango/web/modules/graphicalViews directory and Mango will start. Seeing that stack trace I've seen it before, and graphical views are superceded in the new UI.


  • I deleted the graphicalViews directory but the exception is still being thrown. As a confirmation, I checked the log and the graphicalViews module is no longer being loaded. I also cleared out the work directory to be sure.

    Also, the machine is an Intel Atom.


  • I might've gotten my wires crossed with a different stack trace on that one...

    Googling the exception message suggestions you may be able to disable that specific thing in the JVM you're using, or you could try a different JVM as suggested previously.

    https://askubuntu.com/questions/695560/assistive-technology-not-found-awterror


  • Excellent... thanks! That looks to have worked. :)