Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Migrate Mango to cloud server issue


  • Hi,
    I am trying to migrate Mango over to cloud server.
    I get the error shown below when loading up Mango which I think its something to do with the server setup.
    My current setup status is: I have setup Java at location /usr/java/jdk1.8.0_201-amd64 and I have been unable to get the JAVA_HOME system variable to register in /etc/environment even though I have added JAVA_HOME=/usr/java/jdk1.8.0_201-amd64 to this file. That is when I echo $JAVA_HOME it displays blank.
    Any advice would be appreciated?
    I am trying to get the website to display the usual Mango login screen so I guess I need the new URL to be something like <DOMAIN>:8080/ui/login . Any guides on setting this up? Thanks

    ERROR 2019-03-22T10:06:36,569 (com.serotonin.m2m2.rt.maint.UpgradeCheck.run:66) - store.infiniteautomation.com: Name or service not known 
    java.net.UnknownHostException: store.infiniteautomation.com: Name or service not known
    	at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method) ~[?:1.8.0_201]
    	at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:929) ~[?:1.8.0_201]
    	at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1324) ~[?:1.8.0_201]
    	at java.net.InetAddress.getAllByName0(InetAddress.java:1277) ~[?:1.8.0_201]
    	at java.net.InetAddress.getAllByName(InetAddress.java:1193) ~[?:1.8.0_201]
    	at java.net.InetAddress.getAllByName(InetAddress.java:1127) ~[?:1.8.0_201]
    	at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:45) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:112) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:373) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:381) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:237) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:185) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:89) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:111) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:185) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:83) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:108) ~[httpclient-4.5.5.jar:4.5.5]
    	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:56) ~[httpclient-4.5.5.jar:4.5.5]
    	at com.serotonin.web.http.HttpUtils4.executeWithRetries(HttpUtils4.java:174) ~[mango-3.5.6.jar:?]
    	at com.serotonin.web.http.HttpUtils4.getTextContent(HttpUtils4.java:132) ~[mango-3.5.6.jar:?]
    	at com.serotonin.m2m2.web.dwr.ModulesDwr.getAvailableUpgrades(ModulesDwr.java:382) ~[mango-3.5.6.jar:?]
    	at com.serotonin.m2m2.web.dwr.ModulesDwr.upgradesAvailable(ModulesDwr.java:291) ~[mango-3.5.6.jar:?]
    	at com.serotonin.m2m2.rt.maint.UpgradeCheck.run(UpgradeCheck.java:54) ~[mango-3.5.6.jar:?]
    	at com.serotonin.timer.Task.runTask(Task.java:179) ~[mango-3.5.6.jar:?]
    	at com.serotonin.timer.TaskWrapper.run(TaskWrapper.java:23) ~[mango-3.5.6.jar:?]
    	at com.serotonin.timer.OrderedThreadPoolExecutor$OrderedTaskCollection.run(OrderedThreadPoolExecutor.java:336) ~[mango-3.5.6.jar:?]
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:1.8.0_201]
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:1.8.0_201]
    	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_201]
    

  • Hi Paulppe,

    With regards to the echo $JAVA_HOME, did you log out of your ssh session and back in? The /etc/environment file doesn't automatically update the current user session.

    With regards to the java.net.UnknownHostException at the stack trace this is a DNS issue in the devices configuration or on the network.

    I am trying to get the website to display the usual Mango login screen so I guess I need the new URL to be something like <DOMAIN>:8080/ui/login . Any guides on setting this up? Thanks

    If you have your domain registrar point the domain name at the public IP of your server, and there is not a firewall on a router or whatnot that needs to be punched through, that's all you'd need to do in a basic setup. Change the port to 80 in the env.properties file to lose the port from the URL.


  • As Phil mentioned, logging out and logging in will refresh your environment variables.
    I trust you followed the resource here for installing mango:
    https://help.infiniteautomation.com/linux-installation

    Also enter

     cat /etc/resolv.conf 
    

    into your bash console to ensure you actually have name servers attached to your cloud instance.
    Secondly, if you're already using the server with a webserver, mango won't fire on port 80 if it's already in use.
    If that is the case, configuring a reverse proxy will be your port of call.
    That's all for now

    Fox


  • Hi Phil,
    Thanks for the quick reply.

    1. I now have the Mango login screen displaying on the cloud server. I resolved this by creating a firewall rule to allow traffic through to port 8080 (so effectively port forward). I may need to change to port 80 to lose the port from the URL in the future- thanks for that tip!
    2. The echo $JAVA_HOME. I did log out of ssh session so I think it should work. I need to look into this further but the issue right now may be my lack of linux use. I may need to add JAVA_HOME to the profile file instead.
    3. The java.net.UnknownHostException message at the stack trace- I got this message prior to creating the firewall rule so I need to check for this message when I restart Mango (I can only do this next week so I will keep you posted)
      Great software and great support- much appreciated
      Paul