Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Linux Ubuntu Bacnet can see devices but not read any values


  • I have a Linux Ubuntu and a Win10 running as a dual boot system on the same machine. On Windows Mango BACnet runs perfectly well but I can't get the setup in Linux running properly.

    • I've tried using the same configuration as in Windows: Localbind 192.168.1.106(enp0s25) and Broadcast 192.168.1.255 with no success. Unable to find any Bacnet devices.

    • Then I tried Localbind 0.0.0.0 and Broadcast 192.168.1.255 and now I can see the devices after sending Who-Is and I can also see the available objects in each device after klicking on the "Get Details". Problem is I can not read any values after adding any to my data points.

    Any ideas?

    Thanks


  • Hi Holzatelier, welcome to the forum!

    Have you tried a broadcast address of 255.255.255.255 with the bind address 0.0.0.0 ?

    I suspect it's due to differences in how the operating systems choose to route the broadcast messages.

    Are you sure your points aren't on COV notification and simply not changing? Do you have events from the data source on the linux system? If you are able to get as far as object list requests working, it would seem as though you can poll the present value of objects (since the object list request includes doing that for one of its columns).


  • Hi Phil

    Thanks for your response.

    • The issue seems to have resolved itself over night. When I started this morning the values showed up alright.

    P.S. Broadcast address of 255.255.255.255 with bind adress 0.0.0.0 does not work for me. The devices are not found.