Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Error when attempting SNMP SET


  • When attempting an SNMP SET via mango I am receiving the following error

    : PDU received with error in OID 1.3.6.1.4.1.1718.3.2.3.1.11.1.1.1, text=Bad value 
    

    And here are the mango settings. I have tried multiple combinations of Data Type and Set Type without success, but based on the MIB information the Set Type should be Integer.

    0_1532954690110_7daa661d-8fb6-4243-9b87-64549b78c346-image.png
    0_1532955564314_0c200e64-7ca2-49ce-80ef-b1a1b7b1e5a4-image.png

    When attempting the same SET from another tool I am successful.
    0_1532954610969_2d37e3ad-ea5a-4b16-b8d2-c014b177d771-image.png
    0_1532954626390_783aa445-591c-4dab-a8a8-0577abe5bbff-image.png

    If anyone has any suggestions for additional troubleshooting steps I would be grateful.
    Does the SNMP datasource send the "Set Type" Integer 32 as i=INTEGER or u=INTEGER datatype?

    EDIT: I am able to successfully set this value via the SNMP point import UI, but with the same settings I am unsuccessful via the Old or New data point details page.
    0_1532957203764_82201a65-3417-4d7b-a358-26d79d54694b-image.png

    Thank you.


  • Hi Wingnut2.0,

    I did a little sleuthing and found out,

    1. Integer should be a signed integer 32
    2. Gauge32 should work for unsigned integer 32
    3. Counter32 is distinct from unsigned integer 32, somehow, and this is the comment in the class in SNMP4J (the implementing library):
      The <code>Counter32</code> class allows all the functionality of unsigned
      integers but is recognized as a distinct SMI type, which is used for
      monotonically increasing values that wrap around at 2^32-1 (4294967295).
    

    but my sleuthing also uncovered that about a year ago a bug was committed to make the Integer32 type be sent as the unsigned integer 32 type! Oh no! I have corrected this, and will email you a class override. I bet if you tried it with a 2.8 Mango, it would also work.

    Thanks for bringing this to our attention!


  • I have the same problem, using SNMP-DS 3.4.0 and Core 3.4.4. My data point is set type to Integer 32, but is rejected with "bad type" When I fetch (using wireshark) the traffic I see the module send the wrong data type Gauge32.


  • Hi Juan Pablo Araneda, welcome to the forum!

    You are certainly correct. I didn't release this fix in 3.4 as we were pretty optimistic when I made that post about releasing 3.5 sooner than has ended up happening. However, it will definitely be released as at least a beta this week, and this issue is definitely fixed in 3.5


  • I just released a 3.4.1 SNMP module so that you may have the fix without going to the 3.5 beta immediately.


  • @phildunlap I installed version 3.4.1 and works perfect!
    Thank you.