Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

DataFile Compile Templates fails on Windows vMango 3.3.4


  • I am trying to Compile Templates on a Windows 7 machine and the output is <null> for CSV, Excel, XML and Binary.
    Trying with javac the error is on import com.infiniteautomation.datafilesource....

    Any suggestions?


  • Hi Gordoe,

    Can you post a screenshot of where you are seeing that <null> ? Is there any error in the Mango/logs/ma.log file?

    You could try updating to 3.4, but that doesn't sound like the issue.


  • @phildunlap! 0_1527271568633_Screen Shot 2018-05-25 at 2.05.25 PM.png

    Nothing in the ma.log


  • Hmm. Updating may relieve that. It's odd to me there would be an error for the Binary example importer. Perhaps you are running on a JRE instead of a JDK? That message indicates there was probably a null pointer exception in the compile method in the DWR. I see this if I run on a JRE instead of a JDK, but it may be possible another way, too.


  • I will release 3.4.1 of the data file module today with a better error message for this condition (not having a compiler because it's a JRE instead of a JDK)


  • I've upgraded to 3.4.1 and have put JAVA_HOME= variable in /overide/env.properties but the compile still fails. Compiler not found. Are you running on a JRE?

    Any other suggestions? Is it possible to manually compile it?

    Still, nothing in the ma.log that relates to this.


  • JAVA_HOME would be defined as an environment variable in the OS, so that's Control Panel --> System --> Advanced System Settings --> Environment Variables as C:\path\to\jdk1.8.0_x

    You could also modify your Path environment variable to ensure jdk/bin/ is sooner on the path than jre/bin/ (or remove the jre path entry entirely)

    Are you sure you downloaded a JDK when you installed Java?