Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • HI I have ans ES that I have just deployed on a 4G connection in Australia. I soon after attempted to update, and goth the following message:
    "Your instance cannot be upgraded due to versioning problem: Read timed out"

    Has anyone seen this before?
    I am connecting to it remotely via the 4G connection, and can connect to the internet from site with no problems.

    Hayden


  • See attached screenshot of Upgrade attempt using V3 UI.

    I have another non-ES instance that has dashboardDesigner at 3.1.5, whereas the ES is at 3.1.4


  • Hi Hayden,

    A read timeout could mean there was a disruption between your site and our store, or with our store itself. Have you attempted this many times and always gotten the same result? Were the problem somewhere else in the network, it may have resolved itself by now.

    You can follow manual update instructions and download the modules from the https://store.infiniteautomation.com yourself as one solution.

    Also, I edited out your images because your GUID was included.


  • Thanks Phil,
    Yes have tried many times to update with the same result.

    I am having issues with my 4G provider blocking and/or restricting remote access to the site from outside their network, so this may have something to do with it. I will try taking the ES back to a landine internet connection and attempt the updates to see if it is a 4G problem.

    Are there any other ports that I need to open and/or forward in the router for Mango updates to occur?

    Just for general info:
    When I try to access remotely on 8008 from an ADSL connection, the login page appears, and allows me to input the username and password, then the Mango spinny thing just keeps on spinning!. When I do the same on my cell phone, I can log in correctly and have full access. I am having the same issue with remote access to cameras.

    Is the GUID used as a identifier for cloud access? (I won't have in on the cloud)

    Thanks for your assistance.


  • Internet connectivity is all that's required. Have you checked your logs when you hit the button to see if something else could be occurring?

    To the spinning icon, that could be your ad blocker, so try reloading with it disabled. Perhaps also clear your browser cache.

    I'm not sure what

    (I won't have in on the cloud)

    means. No, the store should not be shunning you.


  • Sorry, I should have said "I won't be using it with the cloud service"

    Its not the cache or the ad blocker, much weirder than that.
    If I try to access via my office WiFi, I don't get past the spinning icon.
    If I then, on the same W8.1 laptop, disconnect from the WiFi, and connect to my android cell phone via the portable hotspot WiFi, I get full access, just by refreshing chrome. !!

    Of course, the cell provider OPTUS/Virgin, have no idea what I am talking about, which is expected.
    But this all is not a fault of your software, so I don't expect you to spend time on it. Just thought I'd put it out there!
    Maybe someone else has some experience in 3G/4G remote connections that has encountered similar before.


  • @hayden_AUS I'd be interested to know what URLs it is failing on. Could you save the output of the browser console and also take a screen shot of the network tab of the developer tools?


  • Hi hayden_AUS

    I have some experience with running Mango units behind 3G services (Telstra) and accessing remotely and via VPN.

    I have a really vague recollection of running in to the same update issue and I think that it was due to the DNS resolver being unavailable. I would perhaps check the DNS settings on the MangoES (it may not be getting the correct one automatically, or may have previously been configured with a DNS server that is not reachable from your 4G connection).

    If that doesn't help, one other thing might be to make sure that the system clock is set correctly on the MangoES. If the date/time is off, this could break SSL connections and that might explain why the IA store is 'timing out'.

    The other connectivity issues you're having (from your office) are mysterious. What equipment are you using for your 4G connection? Are you using an APN that gives you a public IP or are you behind carrier NAT? If you can share a bit more detail about the set up of your remote site and your office I might be able to throw around a couple of ideas.


  • Hi Jeremy, thanks for taking a look at this.

    Logging on to the ES (from my Virgin phone hotspot) on SSH, the DNS server is the router, and the system resolves names no problem.

    Time/date/timezone is also correct.

    The 4G router is a DLink DWR-921, which just takes a SIM. I at some point asked Virgin if the connection would be public, and took screen shots of the CHAT window when they told me YES, it would be accessible. But I'm sure you have had experience trying to get any level of technical information from these representatives. They basically state if you can access Facebook and Google, then what's the problem.

    I'm thinking it is probably has a private address, (1.178.148.xxx), and transfers some data. The router is accessible on 1080, brings up the login box, but then just returns to the login box after clicking login. The CCTV management software shows the recorder online, but no image when accessing a camera.
    With mango, hitting go on the URL http://nnnn.ddns.net:8008, it reaches the login URL http://nnnn.ddns.net:8008/ui/login but just get the spinning logo.

    If I switch to the virgin hotspot on the mobile, everything works.

    I may have to go with a Telstra solution from M2M Connectivity or similar.
    What provider are you running with?

    The remote site is in the bush near Kilkivan Queensland, and I am setting it up as a demo/R&D site for agriculture. I have a business. I've been using Mango for years.

    Hayden


  • Hey hayden_AUS,

    Hmm - 1.178.148.xxx is not a private network (it is publicly routable) so if that is the IP address your Dlink device is getting (and as you likely already know, you'd need to look at the actual address on the device's 4G interface - using a service like 'whatismyipaddress.com' won't show you if you are behind NAT), carrier NAT should not be an issue here.

    Because you're able to access it from your mobile hotspot I don't think that port blocking from Virgin is the issue either. Based on what you've said so far, my guess would be that it's either some strange issue with the Dlink's firewall (in which case, I'd try disabling any firewall functionality completely), some issue with the configuration of your Dlink itself (port forwarding rules or similar) or with your Dynamic DNS service (either the Dynamic DNS provider or the resolver that you use at your office might be slow to update).

    I would continue troubleshooting by first logging in to your router from your (working) hotspot setup, confirming the current 4G/WAN IP address, then probing/attempting to connect to that IP address directly - without using DNS - from another connection.

    I am not working in the industry right now but I have previously used m2mone (sister company of m2mconnectivity) and can't recommend them highly enough.

    The pricing is comparable to what you might pay as a retail customer of Telstra (but you have access to very cheap, low data plans - like a few hundred MB for $3 per month) but of course you have the additional benefit of being able to immediately get access to a support person who is an expert in the field.

    As a m2mone customer you also get access to an extremely powerful and useful web portal that you can use to manage your fleet of SIMs, run diagnostic checks, and even send some commands to the cell tower.

    It's a real no-brainer in my opinion.

    For a remote m2m application like yours, I would also go straight past Dlink and select something ruggedised and industrial from m2mcommunications. The additional investment pays itself off after it saves you making one trip back to your site. The Maestro E228 is probably a good entry-level unit. I personally used many Routerboard RB912 units (with Sierra MC8705 3G module) and while you may need to do some fiddling to get it set up, you cannot beat the value.

    If you want to directly message me some additional details (as much as you are comfortable sharing) I'd be happy to take a quick look in to your networking issue from my end. As you can probably tell, I'm interested in this stuff!


  • Hi Jeremy,

    After trying pretty much everything with the Dlink DWR-921, I decided to swap it out with a Digi Connectport X4 with built in 3G module (and Xbee). I had been using it in the office for my Xbee sensor network.

    The X4 has solved the problem, and I can now connect to the ES and CCTV remotely, no problem. Although it is a bit of a relic now, 2010 vintage, the speed is still pretty good.

    Dlink DWR921 - Of no use for M2M.

    Thanks for you help Jeremy


  • @hayden_aus Great to hear you got things sorted out! Never used Digi but have previously looked at their kit (before landing on Mikrotik, actually) and it seems like nice gear.