Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

libjSSC-2.8_armsf.so no such a file


  • Hi people.

    Im getting this ERROR as mango starts up, my installation is on a Linux 3.10.104 with an armv7l:

    com.infiniteautomation.mango.io.serial.SerialPortConfigException: /root/.jssc/linux/libjSSC-2.8_armsf.so: cannot open the shared file: No such a file

    What is strange is the file it mentions is exactlly there!

    Obviosly I cannot open any serial connection ... so

    If anyone can provide some help on solving this issue would be grea!

    Thanks


  • Hi fidelg,

    It could be a permissions issue. Can you share the result of

    ls -l /root/.jssc/linux/
    

    and the user under which Mango is running?


  • Also check the armsf and armhf text closely. Is it really a soft float device? What's the platform?


  • Thanks 4 the reply, here u have:

    root@odroid-jessie# ls -l /root/.jssc/linux/
    total 11
    -rw-r--r-- 1 root root 10779 mar 13 17:57 libjSSC-2.8_armsf.so

    Im running the mango with the user: admin

    And here the result of my lscpu

    Architecture: armv7l
    Byte Order: Little Endian
    CPU(s): 4
    On-line CPU(s) list: 0-3
    Thread(s) per core: 1
    Core(s) per socket: 4
    Socket(s): 1
    CPU max MHz: 1824.0000
    CPU min MHz: 24.0000


  • The user "admin" is the user within Mango. I am wondering what the operating system user Mango is running under is.

    I expect the answer to be root, because it is autodetecting the path into /root but root can definitely read the file so no permissions issue.

    I don't think that's enough information to determine if it's really a hard float or a soft float, but we can be reasonably confident the correct architecture is being detected (edit: actually, I bet the jssc library copies the .so out of itself based on the jvm version, but I don't know) so this is probably just a curiousity. You can figure out that from the list of supported features for a processor core if you cat /proc/cpuinfo


  • Googling yeilded this thread:

    http://stackoverflow.com/questions/22085552/unsatisfied-link-error-runnable-jar-referencing-jssc-library

    It seems to suggest some people solved their issue by reinstalling java, and one purports to have snagged the armhf.so file out of the jssc jar, placing that into the .jssc/linux/ directory and that solved his problem.

    To unzip a jar you can:

    cd Mango/lib;
    mkdir jssc;
    cp jssc-* jssc;
    cd jssc;
    unzip jssc*;
    #Files should now be in libs/linux/ if you need to grab them