Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Errors when i upgraded the Dashboard module. Dashboard not running


  • I upgraded the dashboard module. Now, when I try to run my dashboard I am getting this error in the console.

    Uncaught TypeError: Cannot read property 'module' of undefined(…) maAppComponents.js:12

    Uncaught TypeError: Cannot read property 'module' of undefined(…)
    serial.js:1 Uncaught SyntaxError: Unexpected token <
    gauge.js:1 Uncaught SyntaxError: Unexpected token <
    pie.js:1 Uncaught SyntaxError: Unexpected token <
    gantt.js:1 Uncaught SyntaxError: Unexpected token <
    amcharts.js:1 Uncaught SyntaxError: Unexpected token <
    blob.js:1 Uncaught SyntaxError: Unexpected token <
    fabric.min.js:1 Uncaught SyntaxError: Unexpected token <
    FileSaver.min.js:1 Uncaught SyntaxError: Unexpected token <
    jszip.min.js:1 Uncaught SyntaxError: Unexpected token <
    pdfmake.min.js:1 Uncaught SyntaxError: Unexpected token <
    xlsx.min.js:1 Uncaught SyntaxError: Unexpected token <
    globalize.js:1 Uncaught SyntaxError: Unexpected token <
    message.js:1 Uncaught SyntaxError: Unexpected token <
    unresolved.js:1 Uncaught SyntaxError: Unexpected token <
    vfs_fonts.js:1 Uncaught SyntaxError: Unexpected token <
    export.js:1 Uncaught SyntaxError: Unexpected token <
    require.js:8 Uncaught Error: Load timeout for modules: angular-material,mdPickers,angular-material-data-table,angular-animate,angular-aria,angular-messages(…)


  • Hi Chris,

    Have you confirmed that the new Dashboards module is getting loaded? You could check that on your Modules (modules.shtm) page, it should show up under 'dashboards'


  • Yes. In the modules page it is showing it there and is paid. Vs. 3.2.4


  • Also. The core is showing 2.7.10


  • Do you have a loadConfig.js in your overrides directory? Try removing it. Also I think you might have overriden the app.js file to add the directive for getting JSON? You will need to copy the latest app.js into overrides and re-apply your changes.


  • I don't have a loadConfig in my overrides? Should I?


  • @atkins.chrisw said in Errors when i upgraded the Dashboard module. Dashboard not running:

    I don't have a loadConfig in my overrides? Should I?

    No, I was just checking. Did you try my second suggestion?


  • I did that. It didnt help. What I finally did is delete the loader.js files and replaced them.

    That seemd to do it.