Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • I'm gonna need just a little more hand holding, but we're at the home stretch.

    Can I get some instructions on how to:

    1. Make dashboards public, without a login required AND without a side bar or top bars.
      I want to load these dashboards on our screens to display them, and it should require no human intervention.
      Is there a link that I can get somewhere going directly to the dashboard?

    0_1475779445523_no bars.png

    1. Give access to a particular user, such as guest, access to some dashboards.
      I created a user guest with a password in Mango.
      This user works to login to the custom dashboards, but it seems to be a separate page than with the admin user.
      The custom menus from admin user are missing from the guest login.

    0_1475779458794_Guest User Created.png

    0_1475779509486_guest permissions.png

    Much thanks and keep up the good work.

  • On the first one try using the Auto Login feature. I use this on my modbile device and it works great:

    I'll let Will or Jared answer the other question.

  • I already tried that, and it didn't work for me, which is why I thought there was something else to it.

    Here's setting the login to guest:

    0_1475784895740_auto login.png

    Here's me trying to login via an incognito window. No auto login is happening.


  • It uses your browser storage to hold the login info so I don't think it will work in Incognito Mode.

  • Oh I see, well we're trying out some different kiosk OSs, on some Raspberry Pis, and I think they run the browser in incognito.

    I'm looking to mimic what PRTG does with their maps. You can get a unique link to each dashboard, or map as they call it.

  • We can look at making the auto login work via URL parameters or something like that in the future, at this time the incognito mode will not work.

    If you create a menu link for your page with a state name that does not start with 'dashboard' then you will not get the menu or top bar when you go to its URL. You could create two menu links for each page, one which is displayed in the menu which starts with 'dashboard' and one which is hidden from the menu that doesn't start with 'dashboard'.

    The second issue I believe is probably due to a bug that was in an earlier version of the dashboards module. Can you post the following markup in your play area and check what the user permission is? I suspect it is empty. If it is empty, change it to user and press save. The edit permission should be edit-menus.

    <ma-json-store xid="custom-user-menu" item="myItem" value="myValue"></ma-json-store>
    <div layout="column">
      <md-input-container class="md-block">
        <label>Edit permission</label>
        <input ng-model="myItem.editPermission">
      <md-input-container class="md-block">
        <label>Read permission</label>
        <input ng-model="myItem.readPermission">
    <md-button class="md-raised md-primary md-hue-3" ng-click="myItem.$save()"><md-icon>save</md-icon> Save</md-button>
    <md-button class="md-raised md-warn" ng-click="myItem.$delete()" disabled><md-icon>delete</md-icon> Delete</md-button>
    <md-button class="md-raised" ng-click="myItem.$get()"><md-icon>undo</md-icon> Revert</md-button>
    <div style="margin-top:10px">
    <pre><code>{{myItem | json}}</code></pre>

  • Hey Jared,

    Regarding the first point:

    I created a page with a link as you described:

    0_1476030349212_page settings.png

    When I use the sidebar to open the page, it works as you described, without a menu.

    0_1476030368867_works from menu.png

    However, when I use the link directly from a new page, by entering the same url, it doesn't open at all. Also, please note it was opened from the same window, just a new tab, so there shouldn't be any login issues. I get the spinning gear icon show up, and then a blank page.

    0_1476030421674_not working direct link.png

    I also noticed, that the View Page link from the page editor also doesn't open the page with the new URL.

    0_1476032687408_second link.png

    Regarding your second point, the permissions were as follows:

    Edit permission: edit-menus
    Read permission: user

    Do I need to give "user" permissions to the "guest" user somewhere?

  • I can't see anything wrong with your configuration, are there any errors in the browsers console? The view page link will open the first menu link it finds that links to the custom page, so it is probably finding the link that doesn't work.

    Yes, make sure your user "guest" has the "user" permission on the users page (/users.shtm).

  • I checked Chrome with Developer Mode and I don't see anything at all in the Console.

    The same issue happens with Firefox as well, if that matters at all.

    I have confirmed again that neither the "View Page" link works, nor opening it directly from the weblink:


    Those same exact links do open from the side bar though.

    edit: I forgot to mention that your permissions suggestions have resolved my issues on that front.

  • @mihairosu
    I've tracked down the bug, can you please test the fix. Replace your app.js file with this one - Dashboards/web/mdAdmin/app.js

    Our schedule does not allow us to release a bug fix to the store right now, sorry.

  • Hey Jared,

    The fix you made won't allow me to open the dashboards module. It seems to be stuck at the gear loading icon. I restored the original apps.js and now it loads ok again.

  • What version of the dashboards module do you have installed? The fix is for 3.2.2, ensure you are on this then apply the fix.

  • 3.2.2

  • Can you open the developer console and tell me if there are errors in the console? What page are you trying to go to?

    I have double checked the fix and can't find a problem with it.

  • I restarted the mango instance after copying over your new file, do you think I need to restart the whole computer? Could that have something to do with it?

    Also there were no errors when I checked it last. I can try it again at some point today.

  • Just to be clear, I am editing the file in the following location?


  • Yes that's the right file, you should not have to restart your computer or even Mango. As long as you clear or disable your cache (on the network tab of Chrome's developer console for example) the new file will be loaded when you refresh the page.

    Joel mentioned that we might have access to your server so we might be able to log in and take a look at what is happening. Perhaps give us a call.

  • Ah, you know what, I don't think I cleared my cache. That might have done it. Give me a little bit and I'll get to it again.

  • Jared, sorry for giving misleading information last time. Your fix worked.

    Thank you.

  • Great, good to hear