Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Build error:taskdef class org.apache.catalina.ant.ReloadTask can not be found


  • Hi,

    I am a wireless module software developer from China, and be interested in your Mango.

    When I try to build Mango sourcecode with the build instruction on https://mango.dev.java.net/#building,

    There is a build error:

    d:\mango\app\build.xml:121: taskdef class org.apache.catalina.ant.ReloadTask can not be found.

    Could you tell me what's the problem?

    Thank you in advance!


  • Hi,

    The ReloadTask is defined near the bottom of the build.xml script (in a taskdef). The "location" attribute points to where the task definition can be found, and uses the macro ${tomcat.home}. This macro is defined in your build.properties file. Make sure you have it properly defined such that it points to the catalina-ant.jar file as it appears in the task definition.


  • I'm having the some kind of problem. I'm trying to make it work under Windows XP, I have installed Tomcat here: C:\Program Files\Apache Software Foundation\Tomcat 6.0

    So I changed the line in build.properties to: tomcat.home=C:\Program Files\Apache Software Foundation\Tomcat 6.0

    And it doesn't work, I still get this message: .

    Buildfile: build.xml
    
    BUILD FAILED
    C:\Documents and Settings\test1234\Pulpit\mango\app\build.xml:120: taskdef class
     org.apache.catalina.ant.ReloadTask cannot be found
    
    Total time: 0 seconds
    

    May someone help me with that?


  • Some things to check:

    1. within that directory, is there a "lib" sub-dir containing "catalina-ant.jar"?
    2. have you tried changing "" characters to "/"?
    3. if all else fails, can you try a directory that does not have embedded spaces?

  • Thanks for the answer, of course changing "" characters to "/" works:)


    1. within that directory, is there a "lib" sub-dir containing "catalina-ant.jar"?