Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

  • M2M2 will not start.
    Core 1.0.1 no modules added
    Ubuntu 10.04.1 LTS

    Bootstrap: 34 jar files loaded
    INFO 2011-03-27 10:34:52,391 (com.serotonin.util.ReloadingProperties.checkForReload:165) - (env) Found updated file(s). Reloading properties
    INFO 2011-03-27 10:34:52,447 (com.serotonin.m2m2.db.DerbyProxy.initializeImpl:55) - Initializing derby connection manager
    INFO 2011-03-27 10:34:56,016 (com.serotonin.m2m2.db.upgrade.DBUpgrade.checkUpgrade:36) - Starting instance with core version 1.0.1
    2011-03-27 10:34:57.054:INFO::Logging to STDERR via org.mortbay.log.StdErrLog
    2011-03-27 10:34:57.219:INFO::jetty-6.1.22
    2011-03-27 10:34:58.214:INFO:/:Initializing Spring root WebApplicationContext
    INFO 2011-03-27 10:34:58,762 (com.serotonin.m2m2.web.M2M2ContextListener.contextInitialized:30) - M2M2 context starting
    INFO 2011-03-27 10:34:58,764 (com.serotonin.m2m2.web.M2M2ContextListener.contextInitialized:38) - M2M2 context started
    2011-03-27 10:34:58.978:INFO:/:Initializing Spring FrameworkServlet 'springDispatcher'
    INFO 2011-03-27 10:35:00,105 (com.serotonin.m2m2.web.dwr.util.BlabberConverterManager.addConverter:61)

    • Probably not an issue: org.jdom.Document is not available so the jdom converter will not load. This is only an problem if you wanted to use it.
      INFO 2011-03-27 10:35:00,106 (com.serotonin.m2m2.web.dwr.util.BlabberConverterManager.addConverter:61)
    • Probably not an issue: org.jdom.Element is not available so the jdom converter will not load. This is only an problem if you wanted to use it.
      2011-03-27 10:35:00.344:INFO::Started SelectChannelConnector@0.0.0.0:8080

    No prompt after this messages.

    Br, Conny Larsson


  • Hi Conny,

    Those are typical startup messages. Have you tried accessing M2M2 at localhost:8080? How do you know it's not starting?


  • Hi Matthew

    No access at 192.168.0.180:8080

    As long as I have the ssh-client(putty) running I can access m2m2.


  • Hmm. Seems like M2M2 is starting ok. The problem may be that Ubuntu closes the application when you log out. Try starting it with "./m2m2-start/sh &". I.e. put a "&" at the end of the command so that a new process is spawned.


  • Hi, Matthew

    It's working now, the "&" solved it.
    Added modules and licenscefile and restarted.
    Now the fun starts :D

    Thank you