Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Problem with initial Mango login - never get the login screen


  • Can't Login after create a default page for "guest" user. All I get is the attempt to bring up the login screen.
    0_1533505435151_Screen Shot 2018-08-05 at 5.43.17 PM.png

    The problem may be related to the fact that I was having a problem viewing the screen associated with main-furnace-heat-pump earlier. Getting permissions right has been difficult.

    Looking in the database I see the following in jsonData.

    0_1533505628368_Screen Shot 2018-08-05 at 5.46.25 PM.png

    Here I can see the link to main-furnace-heat-pump.

    0_1533505693189_Screen Shot 2018-08-05 at 5.47.39 PM.png

    Should I fix this json data? Or should I just delete this record? Or are there other considerations?


  • Hi mlvaelle42,

    Let's not get too ahead of ourselves in messing with the database. The next step is to open your developer tools when trying to load the page to check for errors. If you see some you can post it here and maybe try something like clearing your browser cache. What version is this? Does anything get outputted to Mango/logs/ma.log when you try to load the login page?

    I don't think modifying a page would prevent you from loading the login screen, unless you had somehow kicked off an infinite loop in the instance and it was burning up CPU. Then I would advise restarting Mango.


  • I've cleared browser cache and tried accessing it from other computers with no luck.

    ma.log file looks good to me. My original goal was to bring up a specific web page for "guest" users. I created the web page called "main-furnace-heat-pump" and assigned it to "guest". I'm just not sure that this web page could be viewed by user "guest" at the time I set it up - before I tried a fresh login.

    I cleared browser cache. The login is IPAddress:8080/ui/login. Again, no response after rebooting several times.

    It's as though the default login page is not available - maybe caused by a link to a non-existent web page or one with inappropriate permissions.

    Here's a look at the Chrome developer info.
    0_1533578479567_Screen Shot 2018-08-06 at 2.00.18 PM.png

    Thoughts?


  • Two errors in console, what are they?


  • Sorry, I don't understand "Two errors in console..."


  • There is a console tab in the developer tools, and a red error icon with a count of 2. If you go to the console tab, the errors will be elaborated on.


  • Here are the two errors in Console tab:

    0_1533585149987_Screen Shot 2018-08-06 at 3.52.13 PM.png :


  • Sweet, thanks. I will look into this. Have you tried logging in through the /login.htm page? Perhaps this is only affecting the new login page...You may also be able to explicitly navigate back to /ui/login after it has forwarded you on to the page.

    Did you set up any sort of auto-login for that guest user? Which kind of auto-login?

    You might be able to delete your site cookies for the site and prevent getting redirected from any session lingering from that guest user, or whatever it is.


  • You are attempting to log in as the guest user? I think you should add a readPermission of 'guest' to the edit-menu json store item you showed (or does your guest have 'user' permission?)


  • That did it. Great solution. Thanks.


  • Certainly! Thanks for providing so much information!