Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Display not detected. No hardware specifics

  • I have a MangoES V3 installed and have full access to the Mango software via browser. It appears to function well. However, setting the static IP of the wlan and eth ports has proven frustrating and fruitless. In addition and more importantly, I can not scale the resolution correctly for my monitor connected to the HDMI port. I am currently using an ACER moniter (1366x768) with an hdmi-to-dvi cable. I have tried it with an hdmi-vga-adapter, as well, with no results.
    Can someone please post hardware specifics for this device so I can attempt to locate and use appropriate converters and drivers? I realize that this board is modeled after a Samsung architecture(Hardkernel odroid-xu3 board based on EXYNOS5422...) but without specs I am shooting in the dark.
    If you happen to know of a driver or interface device that would correctthe display problem please respond. The wlan and eth ports are of secondary concern. I am fully functional on a Linux Ubuntu box but I am just learning the Debian branch. Thanks for any advice and I apologize for the length of my post but it's necessary to achieve clarity.

  • Hi Brad, Can you explain the issue with the monitor a bit more and maybe post a photo of what you are seeing. The resolution should be standard HDMI resolution of 1,920x1,200.

    What are you trying to display on the monitor? By default the MangoES HDMI port should just display the command line.

    On the IP issue can you tell me how you have tried to set the IP? Did you do this via the MangoES configuration section on the system setting page?

    Is your Mango and MangoES configuration module running the latest version of Mango 2.8?

  • Thanks for the fast response, Joel. I am getting "Input not valid" displayed. I am just trying to display the CLI. Currently, I am using terminal via putty to access the device. The monitor will respond to keystrokes by energizing but still no visual display.

  • I would try using a standard 1080p resolution screen with HDMI, this is what we use to test each one.

  • Unfortunately, I don't have the ability to change screens. I am installing the ES in place of an existing proprietary workstation. The screens are integrated into the facility manager's security and management center. Will hardware specs be forthcoming so I can try a few other options. Where is the resolution set during initialization?

  • Hi Brad,

    I haven't encountered this exact issue so I'm somewhat guessing, but,

    1. Resolution. I believe the resolution parameters for the hdmi port are those in /media/boot/boot.ini specifically:
      setenv videoconfig "drm_kms_helper.edid_firmware=edid/1920x1080.bin"
      I did not test it but you may be able to modify that to your desired resolution, 1280x720?
      I found useful information about that in this hardkernel thread:
      One of the things they recommend is a kernel update. It's not impossible for that to have externalities.

    2. Font size. There's a decent chance after you get the display working that you may find the font to be large. You can address that with
      sudo dpkg-reconfigure console-setup

  • @phildunlap Thanks, Phil. Please don't think I have ignored the advice. I have been involved with other aspects of setup for the last few days. I will attempt to apply your advice. I will keep you posted and greatly appreciate the input. As a note, every product I have used from infinite automation, software and hardware, is of the highest capability and quality and I am sure that my limited experience with the MangoES is the root cause. Stay tuned..

  • @phildunlap Sorry, Phil. No joy on the config settings. Looks I might need a small machine to act as a display interface. That is unfortunate but without clear specs on the hardware I have created quite a few new problems using outside libraries to try and overcome this problem. I am now in restore mode trying to get back to factory configurations. Is there a method for factory restore that i can use, while protecting my licensing? I have honestly thrown in the towel on the monitor portion of my question. I am on a schedule and must move forward.

  • Hi Brad,

    I'm sorry to hear that. Unfortunately there is not a simple factory-reset built into the Mango ES yet. Has a bad behavior been introduced, or it's to keep the system light?

    Have you tried the same cable to the display you're driving from a system like your personal computer? Does it just work or are there subtleties like setting the resolution?

  • Ok. I am at a point where I must move forward.
    Can you tell me what the recommended GUI config would be for this device?
    Can you tell me which graphics driver should be chosen?
    If "No" to the above, can i protect my licenses if I choose to do a full distro change on the MangoES? To be clear.., Can I remove the factory install Deb distro and install a different distro without loosing use of my licensing purchased with this MangoES?
    I have poured through the forums, tutorials and even requested hardware specifics. I have managed to establish terminal access via HDMI but that is the limit of it. I need a light browser capable gui on this device or I can not use it.

    I would still like to know, moving forward, if you plan to release hardware specs for this device (processor manuf, graphics chipset, firmware specs?. I haven't received an answer to that question. I have had nothing but difficulty configuring this device to do 3 basic things.

  • Hi bwmasterson,

    The MangoES does not come with a GUI operating system.

    With regards to your license, we may make an exception for you, but MangoES licenses are generally not transferable. We prefer to conduct licensing issues through email.

    Those hardward specs for a V3 MangoES would be entirely derived from the specs of the Odroid XU-4. The ES is contributing the power supply, the case, the RS-485 port, power for the system clock, etc. The HDMI port is the port on the Odroid.

    We have developed a version of the ES that has what you're looking for. It boots right to a browser in a lightdm, connected to Mango at localhost in fullscreen mode. However, there were some issues with the Firefox that was available at the time, where some dropdowns in the old UI were impossible to click. This, and a couple other issues (along with limited demand), prevented it from making it all the way forward as a marketed product. It would likely be entirely sufficient and functional if one will only be loading and using a dashboard, as opposed to administrating the whole of Mango. If that's a solution you're interested in knowing more about, I'd encourage you to contact us via phone next week.

  • Phil, apparently I have a corrupt boot,scr file? I have been thru the XU4 forums top to bottom. I attempted to use an sd to rescue boot it and then access the eMMC but no joy. Is there a "hardware key" feature built into the MangoES expansion board? I have solved the display problem but now my tinkering may have caused a new problem. Can I buy a factory eMMC 8GB and field install.

    You have my apologies and I chalk this all up now to my inexperience with the XU4 hardware. I have everything else under control. Thanks for the assistance.

  • There is a switch on the XU4 to boot from SD or eMMC.

    No there is not a hardware key. I think it was the U3 (MangoES v2) had an issue on some units where power would leak from the mini-HDMI port and somehow prevent it from starting again if the mini-HDMI was left connected and the other end was powered, then the power cable was removed and reinserted to the ES. The mini-HDMI port wasn't exposed so not many people ran into this, but it was strange.

    Yes you can buy just an eMMC from us and swap it in the field.

  • @phildunlap I actually solved everything. It was the helper line in the boot.scr and my lack of experience with the arm architecture. After reading the source material you provided and building a platform from the ground up on a similar device I was able to recover the eMMC in place. Thank you.

    16:9 ratio screen works well now and I am exploring different browser solutions to avoid the firefox issues discussed. I feel that I created most of the problems thru inexperience and frustration but I am happy to share any details on the recovery. I am sure others will not have a similar experience.
    One question, if I may? Why use the boot.scr instead of just a boot.ini? The literature I read says that the .scr isn't necessary with the XU4 as it can build/load from the .ini file when no .scr is present.
    The entire boot mechanism is foreign to me and I have had no call to use the mkfile command before. My failure came from editing the .scr directly without "remaking" it. I tried after the boot.ini changes weren't propagated and I caused the boot failure which is quite a problem to overcome. Is it a legacy carryover due to the hardware update? Just curious.

    netboot capability for recovery would be a great addition but I know you guys work very hard on the product to ensure quality. Just a suggestion. Maybe I will work on that at a future date and send you anything interesting.

    Thank you for your expertise, supplied tech input and help!

  • Nice! Thanks for sharing you got it resolved!

    The boot mechanism is mostly foreign to me as well, I haven't had cause to look deeply into it. That's probably why I omitted the apparently crucial step of remaking it :D. Sorry I wasn't able to be more insightful and save you what sounds like an involved process.

    I do believe you are correct that it's a holdover from a OS update. I believe the very first set of XU4's (or maybe I'm confusing myself with the U3 in the V2 boards) only had a boot.scr and when we updated operating system components they modified some things.

    I will start a quick conversation on netboot options, but definitely if you get it assembled we'd love to see what you make.

    Certainly! Thanks for contributing back a willingness to help others with your new expertise!

  • Let me know if you try booting an ES without the .scr file. I read that it works but haven't had time to try it. The benefit is that any edits (even incorrect ones) wouldn't require the mkfile prior to boot and would omit a crucial and fatal mistake by field techs.

    In addition, I found two sources that might be of use.

    1. A generic kms helper file that expands the default resolutions to virtually any display rather a defined resolution. I don't believe that there are any licensing concerns.

    2. After trying multiple bootabe images for a recovery sd card... I found a very basic core image construct that worked perfectly. It allowed me to mount the eMMC partition and edit->make the boot.scr.

    I am happy to share links if you feel its appropriate or I can email them to you for review prior to making them available. I don't want to create a possible security concern on someone else's machine and I am not a Linux expert; just a deployment/ commissioning tech.

  • Yeah I'd definitely be interested in the links. Usually I don't remove people's links unless it's obvious the person is spamming or plugging their own stuff without asking, or if the website tells me I'm a winner immediately if i open it. The more detail you provide in this thread, the more you help out the whole of posterity.

  • Ok, Phil.
    Here is a copy of my boot.ini after repair.

    setenv initrd_high "0xffffffff"
    setenv fdt_high "0xffffffff"
    setenv macaddr "00:1e:06:61:7a:39"
    setenv bootrootfs "console=tty1 console=ttySAC2,115200n8 root=/dev/mmcblk0p2 ro$
    setenv bootcmd "fatload mmc 0:1 0x40008000 zImage; fatload mmc 0:1 0x42000000 u$
    setenv videoconfig "drm_kms_helper.edid_firmware=edid/E2211_21_16-9.bin"
    setenv bootargs "${bootrootfs} ${videoconfig} smsc95xx.macaddr=${macaddr}"

    EDID Database

    Download and install in "/usr/lib/firmware/edid/"

    $ cd /usr/lib/firmware/edid/
    ~/usr/lib/firmware/edid/$ wget ""
    ~/usr/lib/firmware/edid/$ cd /media/boot/
    ~/media/boot/$ ls 
    boot.ini  boot.scrbak  exynos5422-odroidxu3.dtb   uInitrd
    boot.scr  boot.txt     System Volume Information  zImage
    //**backup boot.ini and boot.scr**//
    ~/media/boot/$ sudo cp boot.ini boot.inibak
    ~/media/boot/$ sudo cp boot.scr boot.scrbak
    //**edit boot.ini using E2211-21_16-9.bin**//
    ~/media/boot/$ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.ini boot.scr


  • Great reference for customizing the boot.ini to accomodate various resolutions
    refresh, etc..

    Monitor config parameters in the boot.ini

    Very current minimal odroid img
    ***I have only rescue booted from SD with this img... and then returned my mangoES to factory settings by restoring the eMMC.

  • Also, I have been testing GUI performance using the Iceweasel(MozFirefox for arm7) browser... no limitations so far. I will let you know when the Dashboards are complete.