Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

USB to RS-485 MODBUS Not Detecting Device


  • Hello,

    I am running Mango on my laptop PC running Windows 10.
    I have a Sparkfun USB to RS-485 Converter https://www.sparkfun.com/products/9822
    When I connect a MODBUS device, Thermostat the Mango software does not recognize the device. I have the Salve address and baud rate set correctly, but when I use the "Modbus Read Data" screen and click on the "Read Data" button I always get "No Response from slave 2"

    I also tried 2 other MODBUS devices, another different thermostat and a refrigeration controller and I get exactly the same result.

    I also notice that I can see the TX LED blinking on the USB->RS485 converter, but I never see the RX LED illuminate.

    Any suggestions as to why the Mango software cannot read the slaves devices?


  • Hi tcontrada,

    I wonder if....

    1. Might the device being expecting either ASCII or RTU encoding and you are sending the other?
    2. You've setup this device (the converter) in another configuration you've gotten to work?
    3. I would try changing the 'override timing' setting on the Modbus Serial data source and setting those down to 0 in this bridge configuration you're describing.

    I also wonder if there are descriptions of using this device for Modbus? If you're talking Modbus RTU, there are timing constraints in the protocol specification that some controllers are more persnickity than others, but I wouldn't expect that to be your issue.


  • Hi, thanks for the reply...

    All devices are RTU.
    I did try changing the override timing to zero, but still no response.

    I have not used this specific converter with another program.

    I did install Mango on a RPi3 using the same USB->RS485 converter and I get the same results aw well.

    At this point maybe it is a timing issue or maybe the way 485 works. I have another MODBUS device which does not use 485, but USB to serial and it works on the PC and on the RPi with the Mango software. So in this case the 485 was out of the loop.

    Any suggestions?


  • I would try to get something to work with that adapter, perhaps try flipping the RX and TX wires on one end. If you had another serial converter, I would make a ring back to the computer and test that the adapter is doing what is intended (sending the message out one port, getting it on the other). If you don't, you could check with an oscilloscope that the converter is outputting sensible messages.


  • I did try flipping the RX/TX lines on the 485, did not make a difference.

    Let me ask, what USB to 485 converter have you guys used with success to talk with MODBUS devices with your software running either on a PC or RPi?

    Thanks...


  • Hi,
    Check your converter with [http://www.modbustools.com/modbus_poll.html] . If communication will be ok, check if settings from modbuspoll (slave id, port, baudrate, parity, stop bit, MODBUS FUNCTION, MODBUS REGISTERS) are the same as in Mango.


  • Well, I did use that software last year on something else, so my 30 day trial has expired as I wanted to use it for exactly this issue...

    Thanks...



  • A lot of the time that isn't an issue for us, since our MangoES comes with an onboard RS485 port.

    We have used US Converter's XS890 RS485 converter http://www.usconverters.com/usb-rs485-converter-xs890

    And the optically isolated din-rail variant: http://www.usconverters.com/usb-rs485-isolated-converter

    With great success.