Please Note This forum exists for community support for the Mango product family and the Radix IoT Platform. Although Radix IoT employees participate in this forum from time to time, there is no guarantee of a response to anything posted here, nor can Radix IoT, LLC guarantee the accuracy of any information expressed or conveyed. Specific project questions from customers with active support contracts are asked to send requests to support@radixiot.com.

Radix IoT Website Mango 3 Documentation Website Mango 4 Documentation Website

Data points stopped when updating data point info mango crashes


  • Hi
    i'm having an issue with my Mango installation. We are using ver Mango 2.0.6 against a Derby db, java jdk is 1.7.0_21 and using serial RXTX libs for serial communication. We recently updated our server that hosts the Mango install running all required Windows updates (Windows Server 2008 R2 Enterprise OS) and since then, we have had an issue every time we try to update Data Point data. Right now it looks like it is happening specifically when we try to change the data period and save --> we get an error message that the Data Source has stopped and then Mango stops/crashes.

    It takes us 3 hours to restart/re-init the system so these errors need to be fixed asap. Any ideas?

    here's a bit of the error that is dumped to text file:

    A fatal error has been detected by the Java Runtime Environment:

    EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00000001800087dd, pid=3808, tid=3168

    JRE version: 7.0_21-b11

    Java VM: Java HotSpot(TM) 64-Bit Server VM (23.21-b01 mixed mode windows-amd64 compressed oops)

    Problematic frame:

    C [rxtxSerial.dll+0x87dd] Java_gnu_io_RXTXPort_interruptEventLoop+0x130d

    Core dump written. Default location: C:\m2m2_2.0.6\hs_err_pid3808.mdmp

    If you would like to submit a bug report, please visit:

    http://bugreport.sun.com/bugreport/crash.jsp

    The crash happened outside the Java Virtual Machine in native code.

    See problematic frame for where to report the bug.

    --------------- T H R E A D ---------------

    Current thread (0x0000000012cf9800): JavaThread "qtp1474017256-14851" [_thread_in_native, id=3168, stack(0x0000000011820000,0x0000000011920000)]

    I have confirmed all dlls and paths for java. any idea of why this could be happening? Any help/insight would be greatly appreciated.

    Thanks!


  • Can you post your mango log file for the day this occurs? Should be in your Mango_Home/logs directory. Today's is ma.log, the rest are dated.


  • Sure, here is the file.
    Any help is greatly appreciated. Thanks.

    Attachment: download link


  • I noticed this isn't your mango log, it appears to be the java log. Could you upload your mango log?

    The other thing to preemptively check is whether there is a 64bit rxtxSerial.dll in your mango/overrides folder. I don't think that is causing the issue, but let's be sure we're on the same page.

    Edit, this is no longer the dll I would recommend.

    Attachment: download link


  • sorry, here is the mango log.

    Attachment: download link


  • Are your data sources "Annagrette" and "Beta 1 (Tstat and Acuvim)" mapped to the same serial port by chance (or any of the devices)? Are any other programs interfacing on the serial ports?

    Could you post pictures of the "modbus serial properties" page for those two data sources?

    Also, still just checking, but the rxtxSerial.dll I posted (or an equivalent 64bit rxtx dll) is in your mango/overrides folder, correct?


  • Alright, I think I just ruled out the same COM port possibility.

    I noticed in your subject line you say editing data point properties. Did the crash occur editing a data point property or a data source property?


  • Hi
    yes the crash consistently occurs when editing data point period values.

    thank you for all your help!


  • HI
    all data sources are mapped uniquely, no COM port overlap. And yes, the rxtxSerial.dll is in the overrides folder.

    Thanks.
    Caroline


  • Attached is a file with the screenshots of the modbus serial properties. If you can provide any insight, it would be greatly appreciated.

    Thanks!

    Attachment: download link


  • Okay Caroline,

    I think the problem is in the rxtxSerial.dll (99.9% certain), so I just tested a few other distributions of 64-bit windows rxtxSerial on my own machine, and here's a few distributions with the results of my tests:

    I advise you to try the first (No issues!). To do this, place it into your Mango_Home/overrides folder, and rename it to rxtxSerial.dll.

    The slow boot-up could be caused by a build up of events in your database associated with a particular data source, or it could be a related issue. I'm not sure.

    Attachment: download link


  • Hi,
    thank you for the investigation and help. I tried the other dlls as suggested and unfortunately the issue remains with same error msgs.

    any other suggestions?

    thank you for your help! :)